summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2022-04-05 10:49:15 +0800
committertaotieren2022-04-05 10:49:15 +0800
commit1c3ded725f18a62694f91a447a5a6cb702ee4c58 (patch)
treed13f38beedd1837e840406841d899256fc90bc5d
downloadaur-1c3ded725f18a62694f91a447a5a6cb702ee4c58.tar.gz
update 2022.04
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d80d729e6668
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nuclei-qemu
+ pkgdesc = nuclei-qemu 是 Nuclei Studio IDE 的仿真工具。
+ pkgver = 2022.04
+ pkgrel = 1
+ url = https://www.nucleisys.com/download.php
+ arch = x86_64
+ license = unknow
+ optdepends = nucleistudioide: Nuclei Studio IDE 是基于 MCU Eclipse IDE 开发的一款针对芯来公司处理器核产品的集成开发环境工具,用于 RISC-V 开发继承了 Eclipse IDE 平台的各种优势。
+ optdepends = jlink-software-and-documentation: Segger JLink software & documentation pack for Linux
+ options = !strip
+ source = https://www.nucleisys.com/upload/files/toochain/qemu/nuclei-qemu-2022.04-linux-x64.tar.gz
+ sha256sums = 809dc4d9a4dcdc6358208484919b54870075474943f3e7ef4f390552d17e24e4
+
+pkgname = nuclei-qemu-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7368f3a190ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgbase=nuclei-qemu
+pkgname=(nuclei-qemu-bin)
+pkgver=2022.04
+pkgrel=1
+pkgdesc="nuclei-qemu 是 Nuclei Studio IDE 的仿真工具。"
+arch=("x86_64")
+makedepends=()
+depends=()
+optdepends=('nucleistudioide: Nuclei Studio IDE 是基于 MCU Eclipse IDE 开发的一款针对芯来公司处理器核产品的集成开发环境工具,用于 RISC-V 开发继承了 Eclipse IDE 平台的各种优势。'
+ 'jlink-software-and-documentation: Segger JLink software & documentation pack for Linux')
+conflicts=()
+url="https://www.nucleisys.com/download.php"
+license=('unknow')
+options=(!strip)
+
+source=("https://www.nucleisys.com/upload/files/toochain/qemu/nuclei-qemu-${pkgver}-linux-x64.tar.gz")
+sha256sums=('809dc4d9a4dcdc6358208484919b54870075474943f3e7ef4f390552d17e24e4')
+
+package_nuclei-qemu-bin() {
+ msg2 'Installing Nuclei QEMU'
+ install -dm755 "${pkgdir}/opt/nuclei/NucleiStudio/toolchain/"
+
+ mv "${srcdir}/linux_qemu" "${pkgdir}/opt/nuclei/qemu"
+ ln -sf "/opt/nuclei/qemu" "${pkgdir}/opt/nuclei/NucleiStudio/toolchain/qemu"
+}
+
+#
+# makepkg --printsrcinfo > .SRCINFO
+#
+
+# vim: set ts=8 sw=8 tw=0 noet: