summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Minnocci2020-09-01 17:39:53 +0200
committerFrancesco Minnocci2020-09-01 17:39:53 +0200
commitaaa2ed8dfcf248e9f721eae7d77a3ba813480097 (patch)
tree24fb8c16cab2621a32a26f12851c6fb48b83403a
parent1364a230b2857a5c9b32696c448a4d89c5144c5c (diff)
downloadaur-aaa2ed8dfcf248e9f721eae7d77a3ba813480097.tar.gz
Revive the package: update tag and refactor/modernize PKGBUILD.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
2 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec8bb4792503..ea8fbbbfafd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = nudoku-git
- pkgdesc = Sudoku for the terminal
- pkgver = 0.2.4.r1.g633d5d2
- pkgrel = 1
+ pkgdesc = Ncurses based Sudoku game for the terminal - Git version
+ pkgver = 2.0.0.r16.g676ed93
+ pkgrel = 2
url = https://jubalh.github.io/nudoku/
arch = i686
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = autoconf
depends = ncurses
+ optdepends = cairo: for PDF/PNG output (must be enabled manually with `configure --enable-cairo`)
provides = nudoku
conflicts = nudoku
source = git+https://github.com/jubalh/nudoku.git
diff --git a/PKGBUILD b/PKGBUILD
index 237824ec7d41..c6a917d2f4b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,42 @@
-# Maintainer: Charlie Grado
+# Maintainer: Francesco Minnocci <ascoli dot minnocci at gmail dot com>
+# Contributor: Charlie Grado
pkgname=nudoku-git
_gitname=nudoku
-pkgver=0.2.4.r1.g633d5d2
-pkgrel=1
-pkgdesc="Sudoku for the terminal"
+pkgver=2.0.0.r16.g676ed93
+pkgrel=2
+pkgdesc="Ncurses based Sudoku game for the terminal - Git version"
arch=('i686' 'x86_64')
url="https://jubalh.github.io/nudoku/"
license=('GPL3')
depends=('ncurses')
-makedepends=('git')
+optdepends=('cairo: for PDF/PNG output (must be enabled manually with `configure --enable-cairo`)')
+makedepends=('git' 'autoconf')
provides=('nudoku')
conflicts=('nudoku')
source=("git+https://github.com/jubalh/$_gitname.git")
sha256sums=('SKIP')
pkgver() {
- cd "$_gitname"
+ cd "$srcdir/${_gitname}"
git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$_gitname"
+ cd "$srcdir/${_gitname}"
+
autoreconf -i
- ./configure --prefix=/usr
+ ./configure --prefix=/usr
+ ## To enable PDF/PNG output:
+ # ./configure --prefix=/usr --enable-cairo
make
}
package() {
- cd "$_gitname"
- make install DESTDIR="$pkgdir"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$srcdir/${_gitname}"
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+
+# vim:set ts=2 sw=2 et: