summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-10-06 05:15:27 -0700
committerxiota2023-10-06 05:15:27 -0700
commite05f040a53fa2710861697e3938c444478db7ff5 (patch)
tree8e6ae974ed5a5b920e7bd7ebfcc1dbc9d5d1b802
parent61f097e108cd768aa311044ee531b1a50c1e9c22 (diff)
downloadaur-nullfs.tar.gz
metapackage
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD54
3 files changed, 27 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3ae6fdd0bd7..ddad96684a85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = nullfs
- pkgdesc = FUSE nullfs drivers
- pkgver = latest
+ pkgdesc = metapackage - migrate to fuse-nullfs-git
+ pkgver = 0.0.1
pkgrel = 1
- url = https://github.com/xrgtn/nullfs
+ epoch = 1
arch = any
- license = GPL
- makedepends = git
- depends = fuse
- source = git+https://github.com/xrgtn/nullfs.git
- md5sums = SKIP
pkgname = nul1fs
-
-pkgname = nulnfs
+ depends = fuse-nullfs-git
pkgname = nullfs
+ depends = fuse-nullfs-git
+pkgname = nulnfs
+ depends = fuse-nullfs-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 784cf7c95e88..cbb42a65fc0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,27 @@
-# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
-
-pkgbase=nullfs
-pkgname=(nul1fs nulnfs nullfs)
-pkgver=latest
+# Maintainer:
+
+_newpkg='fuse-nullfs-git'
+_pkgname="nullfs"
+pkgbase="$_pkgname"
+pkgname=(
+ 'nul1fs'
+ 'nullfs'
+ 'nulnfs'
+)
+pkgver=0.0.1
pkgrel=1
-pkgdesc="FUSE nullfs drivers"
+epoch=1
+pkgdesc="metapackage - migrate to $_newpkg"
arch=('any')
-url="https://github.com/xrgtn/nullfs"
-depends=('fuse')
-makedepends=('git')
-license=('GPL')
-source=("git+https://github.com/xrgtn/nullfs.git")
-md5sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/$pkgbase"
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
-}
-
-build() {
- cd "$srcdir/$pkgbase"
-
- make nul1fs
- make nulnfs
- g++ -lfuse -o nullfs nullfs.c++
-}
package_nul1fs() {
- install -Dm 755 "$srcdir/$pkgbase/nul1fs" \
- "$pkgdir/usr/bin/nul1fs"
+ depends=("$_newpkg")
}
package_nulnfs() {
- install -Dm 755 "$srcdir/$pkgbase/nulnfs" \
- "$pkgdir/usr/bin/nulnfs"
-
+ depends=("$_newpkg")
}
package_nullfs() {
- install -Dm 755 "$srcdir/$pkgbase/nullfs" \
- "$pkgdir/usr/bin/nullfs"
-
+ depends=("$_newpkg")
}
-
-# Copy README? LICENSE?