summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfredo Ramos2021-01-20 03:02:42 -0600
committerAlfredo Ramos2021-01-20 03:02:42 -0600
commit00d49671e696d8a1a76cfb21479d9834c488f083 (patch)
tree958765c6c39536222d82c81829ad312f8364028f
parent69a7da0305d6825e89ad0adc89bf4c777ce38e30 (diff)
downloadaur-00d49671e696d8a1a76cfb21479d9834c488f083.tar.gz
Fix package build
The qt5 branch has been merged into the master branch upstreams, and it no longer exists. https://github.com/nulloy/nulloy/commit/4aeb98156a5136df80b93ae9c544878ce3a4dc75
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
-rw-r--r--fix_libdir.patch42
3 files changed, 20 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f870f6fba82..5f13e8f9c37a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nulloy-git
pkgdesc = A music player with a waveform progress bar. Qt5 development version.
- pkgver = 0.8.2.pre46.42.g9b036ea
- pkgrel = 1
+ pkgver = 0.8.2.pre112.0.g7d3a897
+ pkgrel = 2
url = http://nulloy.com/
arch = i686
arch = x86_64
@@ -14,10 +14,9 @@ pkgbase = nulloy-git
depends = gst-plugins-ugly
depends = taglib
depends = hicolor-icon-theme
- depends = desktop-file-utils
- provides = nulloy=0.8.2.pre46.42.g9b036ea
+ provides = nulloy=0.8.2.pre112.0.g7d3a897
conflicts = nulloy
- source = git+https://github.com/nulloy/nulloy.git#branch=qt5
+ source = git+https://github.com/nulloy/nulloy.git
sha512sums = SKIP
pkgname = nulloy-git
diff --git a/PKGBUILD b/PKGBUILD
index fe5c2c3ceccc..fdf60181d897 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
_pkgname=nulloy
pkgname=${_pkgname}-git
-pkgver=0.8.2.pre46.42.g9b036ea
-pkgrel=1
+pkgver=0.8.2.pre112.0.g7d3a897
+pkgrel=2
pkgdesc='A music player with a waveform progress bar. Qt5 development version.'
arch=('i686' 'x86_64')
url='http://nulloy.com/'
license=('GPL')
depends=(
- 'qt5-script' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'taglib'
- 'hicolor-icon-theme' 'desktop-file-utils'
+ 'qt5-script' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly'
+ 'taglib' 'hicolor-icon-theme'
)
makedepends=('qt5-tools' 'git')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-source=('git+https://github.com/nulloy/nulloy.git#branch=qt5')
+source=('git+https://github.com/nulloy/nulloy.git')
sha512sums=('SKIP')
pkgver() {
@@ -47,4 +47,15 @@ package() {
# Install package
cd "${srcdir}"/build
make INSTALL_ROOT="${pkgdir}" install
+
+ # Fix icon installation
+ for size in 16 22 24 32 48 64 96 128
+ do
+ source_file=src/icons/icon-${size}.png
+ dest_file="${pkgdir}"/usr/share/icons/hicolor/${size}x${size}/apps/${_pkgname}.png
+
+ if [[ -f "${source_file}" && ! -f "${dest_file}" ]]; then
+ cp -a "${source_file}" "${dest_file}"
+ fi
+ done
}
diff --git a/fix_libdir.patch b/fix_libdir.patch
deleted file mode 100644
index f016dfa07dc9..000000000000
--- a/fix_libdir.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/configure b/configure
-index 701f65f..68f8b60 100755
---- a/configure
-+++ b/configure
-@@ -1,7 +1,7 @@
- #!/bin/bash
-
- BASENAME=$(basename $0)
--CWD=$(dirname $0)
-+CWD="$(dirname $0)"
- PREFIX=/usr
- LIBDIR=lib
- DEBUG=no
-@@ -84,7 +84,7 @@ while test $# -gt 0; do
- shift
- done
-
--QMAKE_CACHE=$CWD/.qmake.cache
-+QMAKE_CACHE="$CWD"/.qmake.cache
- echo -n > $QMAKE_CACHE
-
- check_executable() {
-@@ -171,7 +171,7 @@ else
- fi
- echo "PREFIX = $PREFIX" >> $QMAKE_CACHE
-
--echo "N_LIBDIR = $LIBDIR" >> $QMAKE_CACHE
-+echo "LIBDIR = $LIBDIR" >> $QMAKE_CACHE
- echo "Library directory: $LIBDIR"
-
- echo "N_CONFIG_SUCCESS = yes" >> $QMAKE_CACHE
-diff --git a/src/src.pro b/src/src.pro
-index 84ef7c6..95e7f11 100644
---- a/src/src.pro
-+++ b/src/src.pro
-@@ -4,5 +4,5 @@ DESTDIR = ..
-
- SRC_DIR = $$PWD
- include($$SRC_DIR/src.pri)
--DEFINES += N_LIBDIR=\""\\\"$${N_LIBDIR}\\\""\"
-+DEFINES += N_LIBDIR=\""\\\"$${LIBDIR}\\\""\"
- SOURCES += $$SRC_DIR/main.cpp