summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfredo Ramos2019-05-24 08:53:21 -0500
committerAlfredo Ramos2019-05-24 08:53:33 -0500
commit40ebe39baa2e0d6579a86c17a000ec423f2f2203 (patch)
tree1c87010c3320990178f73a1b575741af3be22b8a
downloadaur-40ebe39baa2e0d6579a86c17a000ec423f2f2203.tar.gz
Qt5 build
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD59
-rw-r--r--fix_libdir.patch42
3 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72cf833836cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = nulloy-git
+ pkgdesc = A music player with a waveform progress bar. Qt5 development version.
+ pkgver = 0.8.2.pre46.40.gd3534e7
+ pkgrel = 1
+ url = http://nulloy.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = qt5-tools
+ makedepends = git
+ depends = qt5-script
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-plugins-ugly
+ depends = taglib
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ provides = nulloy=0.8.2.pre46.40.gd3534e7
+ conflicts = nulloy
+ source = git+https://github.com/nulloy/nulloy.git#branch=qt5
+ source = fix_libdir.patch
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = nulloy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b059741809d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Alfredo Ramos <alfredo dot ramos at yandex dot com>
+
+_pkgname=nulloy
+pkgname=${_pkgname}-git
+pkgver=0.8.2.pre46.40.gd3534e7
+pkgrel=1
+pkgdesc='A music player with a waveform progress bar. Qt5 development version.'
+arch=('i686' 'x86_64')
+url='http://nulloy.com/'
+license=('GPL')
+
+depends=(
+ 'qt5-script' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'taglib'
+ 'hicolor-icon-theme' 'desktop-file-utils'
+)
+makedepends=('qt5-tools' 'git')
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}")
+
+source=(
+ 'git+https://github.com/nulloy/nulloy.git#branch=qt5'
+ 'fix_libdir.patch'
+)
+sha512sums=(
+ 'SKIP'
+ 'SKIP'
+)
+
+pkgver() {
+ # Update package version
+ cd "${srcdir}"/${_pkgname}
+ git describe --long --tags 2>/dev/null | sed -r 's/^v//;s/-/./g'
+}
+
+prepare() {
+ # Create build directory
+ mkdir -p "${srcdir}"/build
+ cd "${srcdir}"/build
+ cp -R "${srcdir}"/${_pkgname}/* ./
+
+ # Fix LIBDIR
+ patch -Np1 < ../fix_libdir.patch
+}
+
+build() {
+ # Build package
+ cd "${srcdir}"/build
+ ./configure \
+ --prefix /usr \
+ --libdir lib \
+ --no-update-check
+ make
+}
+
+package() {
+ # Install package
+ cd "${srcdir}"/build
+ make INSTALL_ROOT="${pkgdir}" install
+}
diff --git a/fix_libdir.patch b/fix_libdir.patch
new file mode 100644
index 000000000000..f016dfa07dc9
--- /dev/null
+++ b/fix_libdir.patch
@@ -0,0 +1,42 @@
+diff --git a/configure b/configure
+index 701f65f..68f8b60 100755
+--- a/configure
++++ b/configure
+@@ -1,7 +1,7 @@
+ #!/bin/bash
+
+ BASENAME=$(basename $0)
+-CWD=$(dirname $0)
++CWD="$(dirname $0)"
+ PREFIX=/usr
+ LIBDIR=lib
+ DEBUG=no
+@@ -84,7 +84,7 @@ while test $# -gt 0; do
+ shift
+ done
+
+-QMAKE_CACHE=$CWD/.qmake.cache
++QMAKE_CACHE="$CWD"/.qmake.cache
+ echo -n > $QMAKE_CACHE
+
+ check_executable() {
+@@ -171,7 +171,7 @@ else
+ fi
+ echo "PREFIX = $PREFIX" >> $QMAKE_CACHE
+
+-echo "N_LIBDIR = $LIBDIR" >> $QMAKE_CACHE
++echo "LIBDIR = $LIBDIR" >> $QMAKE_CACHE
+ echo "Library directory: $LIBDIR"
+
+ echo "N_CONFIG_SUCCESS = yes" >> $QMAKE_CACHE
+diff --git a/src/src.pro b/src/src.pro
+index 84ef7c6..95e7f11 100644
+--- a/src/src.pro
++++ b/src/src.pro
+@@ -4,5 +4,5 @@ DESTDIR = ..
+
+ SRC_DIR = $$PWD
+ include($$SRC_DIR/src.pri)
+-DEFINES += N_LIBDIR=\""\\\"$${N_LIBDIR}\\\""\"
++DEFINES += N_LIBDIR=\""\\\"$${LIBDIR}\\\""\"
+ SOURCES += $$SRC_DIR/main.cpp