summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-28 21:47:08 +0200
committerChristian Hesse2015-06-28 21:47:08 +0200
commit5ded14f74c85faca276b4f27ad7275437b7e575f (patch)
tree1aed9e2602a15f4e6f88b3c890e0b7a665a726d2
downloadaur-5ded14f74c85faca276b4f27ad7275437b7e575f.tar.gz
initial import of nullshell-git 0.0.6.r0.g967686e-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
-rw-r--r--nullshell.install12
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6eef5135e766
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nullshell-git
+ pkgdesc = do nothing but print keep alive characters, can be used for login shell - git checkout
+ pkgver = 0.0.6.r0.g967686e
+ pkgrel = 1
+ url = https://github.com/eworm-de/nullshell
+ install = nullshell.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = markdown
+ makedepends = git
+ conflicts = nullshell
+ source = git://github.com/eworm-de/nullshell.git
+ sha256sums = SKIP
+
+pkgname = nullshell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b181d6862f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=nullshell-git
+pkgver=0.0.6.r0.g967686e
+pkgrel=1
+pkgdesc="do nothing but print keep alive characters, can be used for login shell - git checkout"
+arch=('i686' 'x86_64')
+makedepends=('markdown' 'git')
+url="https://github.com/eworm-de/nullshell"
+conflicts=('nullshell')
+license=('GPL')
+install=nullshell.install
+source=('git://github.com/eworm-de/nullshell.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd nullshell/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+build() {
+ cd nullshell/
+
+ make
+}
+
+package() {
+ cd nullshell/
+
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/nullshell.install b/nullshell.install
new file mode 100644
index 000000000000..5749d548805d
--- /dev/null
+++ b/nullshell.install
@@ -0,0 +1,12 @@
+post_install() {
+ grep -qe '^/bin/nullshell$' etc/shells || echo '/bin/nullshell' >> etc/shells
+ grep -qe '^/usr/bin/nullshell$' etc/shells || echo '/usr/bin/nullshell' >> etc/shells
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ sed -i -r '/^(\/usr)?\/bin\/nullshell$/d' etc/shells
+}