summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-09-05 23:54:41 +0800
committerChocobo12017-09-06 00:02:03 +0800
commit9f0bd5c2b7aab6704ea2e54ac4684edafd2a85dd (patch)
treed2099fb458f6533dbdd4a2a2d8e23cd8f660c3a2
downloadaur-9f0bd5c2b7aab6704ea2e54ac4684edafd2a85dd.tar.gz
newpkg: numactl-git 2.0.11.r14.gea3a706-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..380db801b508
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = numactl-git
+ pkgdesc = Simple NUMA policy support
+ pkgver = 2.0.11.r14.gea3a706
+ pkgrel = 1
+ url = http://oss.sgi.com/projects/libnuma/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ provides = numactl
+ conflicts = numactl
+ options = staticlibs
+ source = git+https://github.com/numactl/numactl.git
+ sha256sums = SKIP
+
+pkgname = numactl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..435ebab1ecde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=numactl-git
+pkgver=2.0.11.r14.gea3a706
+pkgrel=1
+pkgdesc="Simple NUMA policy support"
+arch=('i686' 'x86_64')
+url="http://oss.sgi.com/projects/libnuma/"
+license=('GPL' 'LGPL')
+depends=('glibc')
+makedepends=('git')
+provides=('numactl')
+conflicts=('numactl')
+options=('staticlibs')
+source=("git+https://github.com/numactl/numactl.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "numactl"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "numactl"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "numactl"
+
+ make check
+}
+
+package() {
+ cd "numactl"
+
+ make DESTDIR="$pkgdir" install
+
+ # move_pages(2) is provided by man-pages and is more up-to-date there anyway
+ rm -r "$pkgdir/usr/share/man/man2"
+}