summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-22 09:05:48 +0800
committerzxp198210052023-12-22 09:05:48 +0800
commit8f681592c25d0c62aab4ff890fd43dbddc0a59b5 (patch)
tree6e18c8264cae5667385774714d6ec7a08e37e86f
parent69bbaf29ccf5aa99e65343f0cee50c00f3eca7d0 (diff)
downloadaur-8f681592c25d0c62aab4ff890fd43dbddc0a59b5.tar.gz
update to 4.3.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD6
-rw-r--r--numara.sh9
3 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cf0b944f262..d714b9a623a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = numara-bin
pkgdesc = Simple notepad calculator built on Electron, powered by Math.js
- pkgver = 4.3.3
+ pkgver = 4.3.4
pkgrel = 1
url = https://numara.io/
arch = x86_64
license = MIT
depends = electron27
depends = hicolor-icon-theme
- provides = numara=4.3.3
+ provides = numara=4.3.4
conflicts = numara
- source = numara-4.3.3.deb::https://github.com/bornova/numara-calculator/releases/download/v4.3.3/Numara-4.3.3-amd64.deb
- source = LICENSE-4.3.3::https://raw.githubusercontent.com/bornova/numara-calculator/v4.3.3/LICENSE
+ source = numara-4.3.4.deb::https://github.com/bornova/numara-calculator/releases/download/v4.3.4/Numara-4.3.4-amd64.deb
+ source = LICENSE-4.3.4::https://raw.githubusercontent.com/bornova/numara-calculator/v4.3.4/LICENSE
source = numara.sh
- sha256sums = 4115b24a4aa0fdf752a551b51f898b4ff003097a18dde076b47ee14443fd4ded
+ sha256sums = 07cbc3cbef002060122e51ee6cf9b4ec7f5cb726624ff221dcff706c6351a6fa
sha256sums = b944c7642b6a0ccf0c24e98d199d8bf4c8d556ebc7d87ddb9af98cab67b378b5
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
pkgname = numara-bin
diff --git a/PKGBUILD b/PKGBUILD
index 706dba5bb1da..da09d0047285 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=numara-bin
_appname=Numara
-pkgver=4.3.3
+pkgver=4.3.4
_electronversion=27
pkgrel=1
pkgdesc="Simple notepad calculator built on Electron, powered by Math.js"
@@ -20,9 +20,9 @@ source=(
"LICENSE-${pkgver}::https://raw.githubusercontent.com/bornova/numara-calculator/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('4115b24a4aa0fdf752a551b51f898b4ff003097a18dde076b47ee14443fd4ded'
+sha256sums=('07cbc3cbef002060122e51ee6cf9b4ec7f5cb726624ff221dcff706c6351a6fa'
'b944c7642b6a0ccf0c24e98d199d8bf4c8d556ebc7d87ddb9af98cab67b378b5'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/numara.sh b/numara.sh
index 2ec4412e5c4f..c77c53567639 100644
--- a/numara.sh
+++ b/numara.sh
@@ -1,14 +1,17 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
+ exit
else
cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+ exit
fi \ No newline at end of file