summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Freitas2023-09-22 10:04:55 +0100
committerJoão Freitas2023-09-22 10:23:23 +0100
commit2d2d5ecfdc87fe8d2351231204baef0f7b2a1fab (patch)
tree69844ed6a37be86fd37d800ac07ff7e0dc546c9f
downloadaur-2d2d5ecfdc87fe8d2351231204baef0f7b2a1fab.tar.gz
v1.6.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76634900e123
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = numbat-bin
+ pkgdesc = A statically typed programming language for scientific computations with first class support for physical dimensions and units
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://github.com/sharkdp/numbat
+ arch = x86_64
+ license = MIT
+ license = Apache-2.0
+ source = numbat-1.6.1.tar.gz::https://github.com/sharkdp/numbat/releases/download/v1.6.1/numbat-1.6.1.tar.gz
+ sha512sums = e956f460514672e4402dab7a2e1ef13b6f815f5314b5f2972f0ba04bf70b8ad5c36484acacaab7f99a5ce722f4c9961a57afab186c48c5633d5b2ba07bb10949
+
+pkgname = numbat-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7959d73e1b5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: João Freitas <joaj.freitas@gmail.com>
+pkgname=numbat-bin
+_pkgname=numbat
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="A statically typed programming language for scientific computations with first class support for physical dimensions and units"
+arch=('x86_64')
+url="https://github.com/sharkdp/numbat"
+license=('MIT' 'Apache-2.0')
+depends=()
+makedepends=()
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/sharkdp/$_pkgname/releases/download/v$pkgver/$_pkgname-$pkgver.tar.gz")
+sha512sums=('e956f460514672e4402dab7a2e1ef13b6f815f5314b5f2972f0ba04bf70b8ad5c36484acacaab7f99a5ce722f4c9961a57afab186c48c5633d5b2ba07bb10949')
+
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "LICENSE-MIT" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE-MIT"
+ install -Dm644 "LICENSE-APACHE" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE-MIT"
+}
+