summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoajfreitas2024-02-15 20:55:18 +0000
committerjoajfreitas2024-02-15 20:55:18 +0000
commita5d3bf3ae530483ef8074f6689c5c822129d8f5e (patch)
tree38ee03e137e64fca9bb782dc2468366be1c0ddef
parentb619237c043f17d03fcfddb134a804623d3b3ba1 (diff)
downloadaur-a5d3bf3ae530483ef8074f6689c5c822129d8f5e.tar.gz
v1.10.1 with .desktop and icons
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7d2fdb10129..19ea14502f24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = numbat-bin
pkgdesc = A statically typed programming language for scientific computations with first class support for physical dimensions and units
pkgver = 1.10.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sharkdp/numbat
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 5764227fbc4f..5237b6d263e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=numbat-bin
_pkgname=numbat
pkgver=1.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="A statically typed programming language for scientific computations with first class support for physical dimensions and units"
arch=('x86_64')
url="https://github.com/sharkdp/numbat"
@@ -16,7 +16,6 @@ sha256sums=(
'b8889a1411a23aed32be5436413632fc55f312937475860107f44281dba961a4'
)
-
package() {
cd "$_pkgname-v$pkgver-x86_64-unknown-linux-gnu"
install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
@@ -25,5 +24,14 @@ package() {
mkdir "$pkgdir/usr/share/$_pkgname"
cp -r "modules" "$pkgdir/usr/share/$_pkgname/modules/"
install -Dm644 "README.md" "$pkgdir/usr/share/doc/$_pkgname/README.md"
+ install -Dm644 "assets/numbat.desktop" "$pkgdir/usr/share/applications/numbat.desktop"
+ install -Dm644 "assets/numbat.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/numbat.svg"
+
+ for icon in $(ls assets/numbat-*.png)
+ do
+ filename_without_prefix=${icon#*-}
+ icon_size=${filename_without_prefix%.*}
+ install -Dm644 "$icon" "$pkgdir/usr/share/icons/hicolor/$icon_size/apps/numbat.png"
+ done
}