summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:10:49 +0200
committerMaxime Gauduin2015-06-08 11:10:49 +0200
commita8b584ab2e234b913d187775f44a2cab2171f861 (patch)
tree04218db948275eb9096ac1e25b716d0da831c3bb
downloadaur-a8b584ab2e234b913d187775f44a2cab2171f861.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--MKPKG7
-rw-r--r--PKGBUILD32
-rw-r--r--numix-bevel-icon-theme.install13
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47074927f784
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = numix-bevel-icon-theme-git
+ pkgdesc = Bevel icon theme from the Numix project
+ pkgver = 0.r10.5f1b191
+ pkgrel = 1
+ url = http://numixproject.org/
+ install = numix-bevel-icon-theme.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = numix-icon-theme-git
+ provides = numix-bevel-icon-theme
+ conflicts = numix-bevel-icon-theme
+ options = !strip
+ source = numix-bevel-icon-theme::git+https://github.com/numixproject/numix-icon-theme-bevel.git
+ sha256sums = SKIP
+
+pkgname = numix-bevel-icon-theme-git
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..e6680b80eca8
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,7 @@
+arch=('any')
+pkgname=('numix-bevel-icon-theme-git')
+builddeps=('numix-icon-theme-git')
+
+check_git $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..069dfcce6694
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Maxime Gauduin <alucryd@gmail.dom>
+
+pkgname=numix-bevel-icon-theme-git
+pkgver=0.r10.5f1b191
+pkgrel=1
+pkgdesc='Bevel icon theme from the Numix project'
+arch=('any')
+url='http://numixproject.org/'
+license=('GPL3')
+depends=('numix-icon-theme-git')
+makedepends=('git')
+provides=('numix-bevel-icon-theme')
+conflicts=('numix-bevel-icon-theme')
+options=('!strip')
+install='numix-bevel-icon-theme.install'
+source=('numix-bevel-icon-theme::git+https://github.com/numixproject/numix-icon-theme-bevel.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd numix-bevel-icon-theme
+
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd numix-bevel-icon-theme
+
+ install -dm 755 "$pkgdir"/usr/share/icons
+ cp -dr --no-preserve=ownership Numix-Bevel "$pkgdir"/usr/share/icons/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/numix-bevel-icon-theme.install b/numix-bevel-icon-theme.install
new file mode 100644
index 000000000000..1caa9ab0eaeb
--- /dev/null
+++ b/numix-bevel-icon-theme.install
@@ -0,0 +1,13 @@
+post-install() {
+ gtk-update-icon-cache -ftq usr/share/icons/Numix-Bevel
+}
+
+post-upgrade() {
+ post-install
+}
+
+post-remove() {
+ post-install
+}
+
+# vim: ts=2 sw=2 et: