summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:10:51 +0200
committerMaxime Gauduin2015-06-08 11:10:51 +0200
commit27cdab10a4db9c39147805bb966d22bf6aa20032 (patch)
tree2a2b52c56949b07916673359ceef2afe65f82ab7
downloadaur-27cdab10a4db9c39147805bb966d22bf6aa20032.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--MKPKG7
-rw-r--r--PKGBUILD32
-rw-r--r--numix-circle-icon-theme.install14
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cdb2d406d03e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = numix-circle-icon-theme-git
+ pkgdesc = Circle icon theme from the Numix project
+ pkgver = 0.r1677.fe74d83
+ pkgrel = 1
+ url = http://numixproject.org/
+ install = numix-circle-icon-theme.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = numix-icon-theme-git
+ provides = numix-circle-icon-theme
+ provides = numix-circle-light-icon-theme
+ conflicts = numix-circle-icon-theme
+ conflicts = numix-circle-light-icon-theme
+ options = !strip
+ source = numix-circle-icon-theme::git+https://github.com/numixproject/numix-icon-theme-circle.git
+ sha256sums = SKIP
+
+pkgname = numix-circle-icon-theme-git
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..76bf00a9416d
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,7 @@
+arch=('any')
+pkgname=('numix-circle-icon-theme-git')
+builddeps=('numix-icon-theme-git')
+
+check_git $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5c419e5581a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=numix-circle-icon-theme-git
+pkgver=0.r1677.fe74d83
+pkgrel=1
+pkgdesc='Circle icon theme from the Numix project'
+arch=('any')
+url='http://numixproject.org/'
+license=('GPL3')
+depends=('numix-icon-theme-git')
+makedepends=('git')
+provides=('numix-circle-icon-theme' 'numix-circle-light-icon-theme')
+conflicts=('numix-circle-icon-theme' 'numix-circle-light-icon-theme')
+options=('!strip')
+install='numix-circle-icon-theme.install'
+source=('numix-circle-icon-theme::git+https://github.com/numixproject/numix-icon-theme-circle.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd numix-circle-icon-theme
+
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd numix-circle-icon-theme
+
+ install -dm 755 "${pkgdir}"/usr/share/icons
+ cp -dr --no-preserve='ownership' Numix-Circle{,-Light} "${pkgdir}"/usr/share/icons/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/numix-circle-icon-theme.install b/numix-circle-icon-theme.install
new file mode 100644
index 000000000000..f513a1cf6bdd
--- /dev/null
+++ b/numix-circle-icon-theme.install
@@ -0,0 +1,14 @@
+post-install() {
+ gtk-update-icon-cache -ftq usr/share/icons/Numix-Circle
+ gtk-update-icon-cache -ftq usr/share/icons/Numix-Circle-Light
+}
+
+post-upgrade() {
+ post-install
+}
+
+post-remove() {
+ post-install
+}
+
+# vim: ts=2 sw=2 et: