summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2015-08-27 15:11:42 +0200
committerPieter Goetschalckx2015-08-27 15:11:42 +0200
commit83ae5bf54af9b4b8f33bee76f36b8e95796183a6 (patch)
tree6a7982514bdff42ea5dffafd1403882acff79136
downloadaur-83ae5bf54af9b4b8f33bee76f36b8e95796183a6.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2356c957f575
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = numix-folders-git
+ pkgdesc = Alternate folders for use with the Numix base icon theme.
+ pkgver = r346.1033a15
+ pkgrel = 1
+ url = https://github.com/numixproject/numix-folders
+ arch = any
+ license = GPL3
+ depends = numix-themes-git
+ depends = python-gobject
+ depends = gksu
+ source = numix-folders::git+https://github.com/numixproject/numix-folders
+ md5sums = SKIP
+
+pkgname = numix-folders-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d8e348186f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
+
+pkgname=numix-folders-git
+pkgver=r346.1033a15
+pkgrel=1
+pkgdesc="Alternate folders for use with the Numix base icon theme."
+arch=('any')
+url="https://github.com/numixproject/numix-folders"
+license=('GPL3')
+depends=('numix-themes-git' 'python-gobject' 'gksu')
+source=("numix-folders::git+https://github.com/numixproject/numix-folders")
+md5sums=('SKIP')
+
+pkgver() {
+ cd numix-folders
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd numix-folders
+ rm -rf .git LICENSE README.md
+}
+
+package() {
+ cd numix-folders
+
+ install -dm 755 "$pkgdir/usr/share/numix-folders"
+ install -dm 755 "$pkgdir/usr/bin"
+
+ cp -dr --no-preserve='ownership' * "$pkgdir/usr/share/numix-folders/"
+ ln -s /usr/share/numix-folders/numix-folders $pkgdir/usr/bin/numix-folders
+}
+
+# vim:set ts=2 sw=2 et:
+