summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2022-06-12 15:42:28 -0400
committerneeshy2022-06-12 15:42:28 -0400
commit4337d0d35502dc6d28894b7bf28ae4f7b78a7fb1 (patch)
tree16e77e967f30e6a578021658494051a7df32441d
downloadaur-4337d0d35502dc6d28894b7bf28ae4f7b78a7fb1.tar.gz
numix-frost-themes-git: initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e55e8c3b0c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = numix-frost-themes-git
+ pkgdesc = A modern flat theme with a combination of light and dark elements - Antergos Edition
+ pkgver = latest
+ pkgrel = 1
+ url = https://numixproject.github.io/
+ arch = any
+ license = GPL3
+ makedepends = gdk-pixbuf2
+ makedepends = glib2
+ makedepends = ruby-sass
+ depends = gtk-engine-murrine
+ provides = numix-frost-themes
+ conflicts = numix-frost-themes
+ source = git+https://github.com/Antergos/Numix-Frost.git
+ source = Numix-Frost-Light::git+https://github.com/Antergos/Numix-Frost.git#branch=numix-frost-light
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = numix-frost-themes-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d706781aaa6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: neeshy <neeshy@tfwno.gf>
+pkgname=numix-frost-themes-git
+pkgver=latest
+pkgrel=1
+pkgdesc="A modern flat theme with a combination of light and dark elements - Antergos Edition"
+arch=('any')
+url="https://numixproject.github.io/"
+license=('GPL3')
+depends=('gtk-engine-murrine')
+makedepends=('gdk-pixbuf2' 'glib2' 'ruby-sass')
+provides=('numix-frost-themes')
+conflicts=('numix-frost-themes')
+source=("git+https://github.com/Antergos/Numix-Frost.git"
+ "Numix-Frost-Light::git+https://github.com/Antergos/Numix-Frost.git#branch=numix-frost-light")
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/Numix-Frost"
+ make
+
+ cd "$srcdir/Numix-Frost-Light"
+ make
+}
+
+package() {
+ cd "$srcdir/Numix-Frost"
+ make DESTDIR="$pkgdir" install
+
+ cd "$srcdir/Numix-Frost-Light"
+ make DESTDIR="$pkgdir" install
+}