summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-02-26 12:38:51 +0100
committerMaxime Gauduin2017-02-26 12:38:51 +0100
commit80f61da16c9a65b9a57a37174d72a2de8efc3ddb (patch)
treeb1954d33855061f5de2b3ab73a5f5e1a56f5d6c4
downloadaur-80f61da16c9a65b9a57a37174d72a2de8efc3ddb.tar.gz
And rename the directory as well
-rw-r--r--.SRCINFO23
-rw-r--r--MKPKG7
-rw-r--r--PKGBUILD37
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9eb24a68005a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Feb 26 11:37:49 UTC 2017
+pkgbase = numix-gtk-theme-git
+ pkgdesc = A flat and light theme with a modern look (GNOME, Openbox, Unity, Xfce)
+ pkgver = 2.6.6.r18.f25d7e0
+ pkgrel = 1
+ url = http://numixproject.org/
+ arch = any
+ license = GPL3
+ makedepends = gdk-pixbuf2
+ makedepends = git
+ makedepends = glib2
+ makedepends = libxml2
+ makedepends = ruby-sass
+ optdepends = gtk-engine-murrine: GTK2 theme engine
+ provides = numix-gtk-theme
+ conflicts = numix-gtk-theme
+ replaces = numix-themes-git
+ source = git+https://github.com/numixproject/numix-gtk-theme.git
+ md5sums = SKIP
+
+pkgname = numix-gtk-theme-git
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..ee2f4d44c173
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,7 @@
+arch=('any')
+pkgname=('numix-gtk-theme-git')
+builddeps=('ruby-maruku' 'ruby-yard' 'ruby-sass')
+
+check_git $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c481ec53ca0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Diego <cdprincipe@gmail.com>
+
+pkgname=numix-gtk-theme-git
+pkgver=2.6.6.r18.f25d7e0
+pkgrel=1
+pkgdesc='A flat and light theme with a modern look (GNOME, Openbox, Unity, Xfce)'
+arch=('any')
+url='http://numixproject.org/'
+license=('GPL3')
+makedepends=('gdk-pixbuf2' 'git' 'glib2' 'libxml2' 'ruby-sass')
+optdepends=('gtk-engine-murrine: GTK2 theme engine')
+provides=('numix-gtk-theme')
+conflicts=('numix-gtk-theme')
+replaces=('numix-themes-git')
+source=('git+https://github.com/numixproject/numix-gtk-theme.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd numix-gtk-theme
+
+ git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./'
+}
+
+build() {
+ cd numix-gtk-theme
+
+ make
+}
+
+package() {
+ cd numix-gtk-theme
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: