summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBilal Elmoussaoui2016-11-10 01:15:24 +0100
committerBilal Elmoussaoui2016-11-10 01:15:24 +0100
commit852e303eb2717ec138ef05f63cb43f485bd626f2 (patch)
treed7024b82c14bb9ee3a3e9fdfb922ee776dd38756
downloadaur-852e303eb2717ec138ef05f63cb43f485bd626f2.tar.gz
first release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91683d264e06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = numix-square-icon-theme-git
+ pkgdesc = Square icon theme from the Numix project
+ pkgver = 0.r3.3773866
+ pkgrel = 1
+ url = http://numixproject.org/
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = numix-icon-theme-git
+ provides = numix-square-icon-theme
+ provides = numix-square-light-icon-theme
+ conflicts = numix-square-icon-theme
+ conflicts = numix-square-light-icon-theme
+ options = !strip
+ source = numix-square-icon-theme::git+https://github.com/numixproject/numix-icon-theme-square.git
+ sha256sums = SKIP
+
+pkgname = numix-square-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54ba923be243
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Bilal Elmoussaoui <bil.elmoussaoui@gmail.com>
+
+pkgname=numix-square-icon-theme-git
+pkgver=0.r3.3773866
+pkgrel=1
+pkgdesc='Square icon theme from the Numix project'
+arch=('any')
+url='http://numixproject.org/'
+license=('GPL3')
+depends=('numix-icon-theme-git')
+makedepends=('git')
+provides=('numix-square-icon-theme' 'numix-square-light-icon-theme')
+conflicts=('numix-square-icon-theme' 'numix-square-light-icon-theme')
+options=('!strip')
+source=('numix-square-icon-theme::git+https://github.com/numixproject/numix-icon-theme-square.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd numix-square-icon-theme
+
+ echo "0.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd numix-square-icon-theme
+
+ install -dm 755 "${pkgdir}"/usr/share/icons
+ cp -dr --no-preserve='ownership' Numix-Square{,-Light} "${pkgdir}"/usr/share/icons/
+}