summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYan Doroshenko2018-07-16 13:35:53 +0200
committerYan Doroshenko2018-07-16 13:35:53 +0200
commit756d491217be0e0e5bdf7acd72a23d4f2b5982fc (patch)
tree9dab964fc9da033844b73aa5290b689cc856cc7f
downloadaur-756d491217be0e0e5bdf7acd72a23d4f2b5982fc.tar.gz
[new] Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--Gemfile2
-rw-r--r--PKGBUILD65
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..133b6593a231
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = numix-themes-archblue
+ pkgdesc = A flat and light theme with a modern look and softer accents (GNOME, Openbox, Unity, Xfce) using the ArchLinux blue (#1793d1) and dark grey (#333333) colors
+ pkgver = 2.6.6.r50.5869b68
+ pkgrel = 1
+ url = https://github.com/shimmerproject/Numix.git
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = ruby-bundler
+ makedepends = inkscape
+ depends = gtk-engine-murrine
+ source = git+https://github.com/shimmerproject/Numix.git
+ source = Gemfile
+ sha256sums = SKIP
+ sha256sums = b1061ba7ce09c9eb3e41f59362aa8c21d27073b0658f13fb5eabdaea654afe2c
+
+pkgname = numix-themes-archblue
+
diff --git a/Gemfile b/Gemfile
new file mode 100644
index 000000000000..3f76dd555ee0
--- /dev/null
+++ b/Gemfile
@@ -0,0 +1,2 @@
+source "https://rubygems.org"
+gem "sass"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f297e530766
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Yan Doroshenko <yandoroshenko@protonmail.com>
+# Contributor: Yan Doroshenko <yandoroshenko@protonmail.com>
+# Contributor: Dan Elkouby <streetwalrus@codewalr.us>
+
+pkgname=numix-themes-archblue
+pkgver=2.6.6.r50.5869b68
+pkgrel=1
+pkgdesc='A flat and light theme with a modern look and softer accents (GNOME, Openbox, Unity, Xfce) using the ArchLinux blue (#1793d1) and dark grey (#333333) colors'
+arch=('any')
+url='https://github.com/shimmerproject/Numix.git'
+license=('GPL3')
+depends=('gtk-engine-murrine')
+makedepends=('git' 'ruby-bundler' 'inkscape')
+source=("git+https://github.com/shimmerproject/Numix.git"
+ "Gemfile")
+sha256sums=('SKIP'
+ 'b1061ba7ce09c9eb3e41f59362aa8c21d27073b0658f13fb5eabdaea654afe2c')
+
+pkgver() {
+ cd Numix
+
+ git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./'
+}
+
+prepare() {
+ cd Numix/src
+
+ # Kill it all
+ ORANGE=('f0544c' 'd64937' 'f1544d' 'f06860' 'fc6f5d')
+ GRAY=('444444')
+ for FILE in $(find -type f)
+ do
+ for O in ${ORANGE[@]}
+ do
+ sed -i "s/#${O}/#1793d1/g" "${FILE}"
+ done
+ for G in ${GRAY[@]}
+ do
+ sed -i "s/#${G}/#333333/g" "${FILE}"
+ done
+ sed -i 's/Numix/Numix-Archblue/' "${FILE}"
+ done
+
+ cd assets
+ rm -f *.png
+ SVG="all-assets.svg"
+ for FILE in $(cat all-assets.txt)
+ do
+ inkscape "${SVG}" -i "EXP-${FILE}" -e "${FILE}.png"
+ inkscape "${SVG}" -i "EXP-${FILE}" -d 192 -e "${FILE}@2.png"
+ done
+}
+
+build() {
+ cd Numix
+
+ bundle install --path .
+ make SASS="bundle exec sass"
+}
+package() {
+ cd Numix
+
+ install -dm 755 "$pkgdir"/usr/share/themes/Numix-Archblue
+ cp -dr --no-preserve='ownership' src/* "$pkgdir"/usr/share/themes/Numix-Archblue/
+}