summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Elkouby2016-04-16 11:57:13 +0300
committerDan Elkouby2016-04-16 11:57:13 +0300
commit85b9f8268a1d77043fdd19fac94341e060d76715 (patch)
tree8548c734e84226a65bbbfb292622f3176a37d00e
parent93af280a48d0d9f2582372309ca0beba8e2c0547 (diff)
downloadaur-85b9f8268a1d77043fdd19fac94341e060d76715.tar.gz
Move to -git
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore2
-rw-r--r--Gemfile2
-rw-r--r--PKGBUILD47
4 files changed, 54 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c91ba87cbbd3..e80ef65e2daa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,22 @@
# Generated by mksrcinfo v8
-# Thu Mar 31 10:27:20 UTC 2016
-pkgbase = numix-themes-blue
+# Sat Apr 16 08:56:49 UTC 2016
+pkgbase = numix-themes-blue-git
pkgdesc = A flat and light theme with a modern look and softer accents (GNOME, Openbox, Unity, Xfce)
- pkgver = 2.5.1
- pkgrel = 2
+ pkgver = 2.5.1.r199.bde0a73
+ pkgrel = 1
url = http://numixproject.org/
arch = any
license = GPL3
+ makedepends = git
+ makedepends = ruby-bundler
+ makedepends = svg2png
depends = gtk-engine-murrine
- source = numix-themes-2.5.1.tar.gz::https://github.com/shimmerproject/Numix/archive/v2.5.1.tar.gz
- sha256sums = 64b0c34c49633879c8b0b9b685da7b927501ab6db265db15fed04705c04f935b
+ conflicts = numix-themes-blue
+ replaces = numix-themes-blue
+ source = git+https://github.com/shimmerproject/Numix.git
+ source = Gemfile
+ sha256sums = SKIP
+ sha256sums = b1061ba7ce09c9eb3e41f59362aa8c21d27073b0658f13fb5eabdaea654afe2c
-pkgname = numix-themes-blue
+pkgname = numix-themes-blue-git
diff --git a/.gitignore b/.gitignore
index 6cfb1eb89185..1585c1614bc5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
/src/
/pkg/
-numix-themes-*.tar.gz
+/Numix/
*.pkg.tar.xz
diff --git a/Gemfile b/Gemfile
new file mode 100644
index 000000000000..3f76dd555ee0
--- /dev/null
+++ b/Gemfile
@@ -0,0 +1,2 @@
+source "https://rubygems.org"
+gem "sass"
diff --git a/PKGBUILD b/PKGBUILD
index 7d7cc1cee212..6d830a5a25d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,60 @@
+# $Id$
# Maintainer: Dan Elkouby <streetwalrus@codewalr.us>
# Contributor: Dan Elkouby <streetwalrus@codewalr.us>
-pkgname=numix-themes-blue
-pkgver=2.5.1
-pkgrel=2
+pkgname=numix-themes-blue-git
+pkgver=2.5.1.r199.bde0a73
+pkgrel=1
pkgdesc='A flat and light theme with a modern look and softer accents (GNOME, Openbox, Unity, Xfce)'
arch=('any')
url='http://numixproject.org/'
license=('GPL3')
depends=('gtk-engine-murrine')
-source=("numix-themes-${pkgver}.tar.gz::https://github.com/shimmerproject/Numix/archive/v${pkgver}.tar.gz")
-sha256sums=('64b0c34c49633879c8b0b9b685da7b927501ab6db265db15fed04705c04f935b')
+makedepends=('git' 'ruby-bundler' 'svg2png')
+conflicts=('numix-themes-blue')
+replaces=('numix-themes-blue')
+source=("git+https://github.com/shimmerproject/Numix.git"
+ "Gemfile")
+sha256sums=('SKIP'
+ 'b1061ba7ce09c9eb3e41f59362aa8c21d27073b0658f13fb5eabdaea654afe2c')
+
+pkgver() {
+ cd Numix
+
+ git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./'
+}
prepare() {
- cd Numix-${pkgver}
+ cd Numix
- for FILE in `find -type f`
+ for FILE in $(find -path ./.\* -prune -o -type f -print)
do
- sed -i 's/#fc6f5d/#428de7/g' "${FILE}"
+ sed -i 's/#f0544c/#2d81e5/g' "${FILE}"
sed -i 's/#d64937/#2d81e5/g' "${FILE}"
sed -i 's/Numix/Numix-Blue/' "${FILE}"
done
+
+ cd gtk-3.0/assets
+ rm -f *.png
+ for FILE in *.svg
+ do
+ OUTNAME=$(echo ${FILE} | sed -e "s/selected/checked/" -e "s/\\.svg$/.png/")
+ svg2png ${FILE} ${OUTNAME}
+ done
+}
+
+build() {
+ cd Numix
+
+ bundle install --path .
+ make SASS="bundle exec sass"
}
package() {
- cd Numix-${pkgver}
+ cd Numix
install -dm 755 "$pkgdir"/usr/share/themes/Numix-Blue
- rm -rf .git .gitignore CREDITS LICENSE README.md
cp -dr --no-preserve='ownership' * "$pkgdir"/usr/share/themes/Numix-Blue/
+ rm -rf "$pkgdir"/usr/share/themes/Numix-Blue/{CREDITS,LICENSE,Makefile,README.md}
}
# vim: ts=2 sw=2 et: