summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:10:56 +0200
committerMaxime Gauduin2015-06-08 11:10:56 +0200
commit975ca885f32041b6bbfd5c274ef8a626288fcd85 (patch)
tree74a127906ee3f814714c4740217d93714af727f0
downloadaur-975ca885f32041b6bbfd5c274ef8a626288fcd85.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--MKPKG6
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9977e577776f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = numix-themes-git
+ pkgdesc = A flat and light theme with a modern look (GNOME, Openbox, Unity, Xfce)
+ pkgver = 2.5.1.r11.c05a9fd
+ pkgrel = 1
+ url = http://numixproject.org/
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk-engine-murrine
+ provides = numix-themes
+ conflicts = numix-themes
+ source = numix-themes::git+https://github.com/shimmerproject/Numix.git
+ md5sums = SKIP
+
+pkgname = numix-themes-git
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..dc4127e92c0a
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,6 @@
+arch=('any')
+pkgname=('numix-themes-git')
+
+check_git $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b072e3921c08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Diego <cdprincipe@gmail.com>
+
+pkgname=numix-themes-git
+pkgver=2.5.1.r11.c05a9fd
+pkgrel=1
+pkgdesc='A flat and light theme with a modern look (GNOME, Openbox, Unity, Xfce)'
+arch=('any')
+url='http://numixproject.org/'
+license=('GPL3')
+depends=('gtk-engine-murrine')
+makedepends=('git')
+provides=('numix-themes')
+conflicts=('numix-themes')
+source=('numix-themes::git+https://github.com/shimmerproject/Numix.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd numix-themes
+
+ printf "%s" "$(git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./')"
+ #printf "2.5.1.r%s.%s" "$(git rev-list --count v2.4..HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd numix-themes
+
+ install -dm 755 "${pkgdir}"/usr/share/themes/Numix
+ rm -rf .git .gitignore CREDITS LICENSE README.md
+ cp -dr --no-preserve='ownership' * "${pkgdir}"/usr/share/themes/Numix/
+}
+
+# vim: ts=2 sw=2 et: