summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrimi2017-10-07 06:19:03 +0200
committergrimi2017-10-07 06:19:03 +0200
commit49822611044acae522ccb15ae2e80c608597917d (patch)
tree722315aca0f599f46e1f6f42c8a218696e800f6d
parentc8483233cfafafde62b383effbe88b086db76cbd (diff)
downloadaur-49822611044acae522ccb15ae2e80c608597917d.tar.gz
Upstream: 2.6.7
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d22e865aa51..d3e3ce71696f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = numix-themes-green
pkgdesc = A flat and light theme with a modern look using Green color (GNOME, MATE, Openbox, Unity, XFCE)
- pkgver = 2.6.6.r27.582f09f
+ pkgver = 2.6.7
pkgrel = 1
url = http://numixproject.org/
arch = any
license = GPL3
- makedepends = git
makedepends = ruby-bundler
makedepends = inkscape
depends = gtk-engine-murrine
- source = git+https://github.com/numixproject/numix-gtk-theme.git#commit=582f09f
- sha256sums = SKIP
+ source = numix-themes-2.6.7.tar.gz::https://github.com/numixproject/numix-gtk-theme/archive/2.6.7.tar.gz
+ sha256sums = 4590c6077828d73aecbc2521acf5b8d4669aacff1e9d09575888be67f2dc0d1b
pkgname = numix-themes-green
diff --git a/PKGBUILD b/PKGBUILD
index f44daf8cb0c8..8816b724839f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,21 @@
# Maintainer: grimi <grimi at poczta dot fm>
pkgname=numix-themes-green
-pkgver=2.6.6.r27.582f09f
+pkgver=2.6.7
pkgrel=1
pkgdesc="A flat and light theme with a modern look using Green color (GNOME, MATE, Openbox, Unity, XFCE)"
arch=('any')
url='http://numixproject.org/'
license=('GPL3')
depends=('gtk-engine-murrine')
-makedepends=('git' 'ruby-bundler' 'inkscape')
-source=("git+https://github.com/numixproject/numix-gtk-theme.git#commit=582f09f")
-sha256sums=('SKIP')
-
-
-
-pkgver() {
- cd numix-gtk-theme
- git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./'
-}
+makedepends=('ruby-bundler' 'inkscape')
+source=("${pkgname%-*}-${pkgver}.tar.gz::https://github.com/numixproject/numix-gtk-theme/archive/${pkgver}.tar.gz")
+sha256sums=('4590c6077828d73aecbc2521acf5b8d4669aacff1e9d09575888be67f2dc0d1b')
prepare() {
local color="#697740" name="Green"
- cd numix-gtk-theme/src
+ cd numix-gtk-theme-${pkgver}/src
for file in gtk-2.0/gtkrc \
gtk-3.0/scss/_global.scss \
assets/*.svg \
@@ -53,14 +46,14 @@ prepare() {
build() {
- cd numix-gtk-theme
+ cd numix-gtk-theme-${pkgver}
bundle install --path .
make SASS="bundle exec sass"
}
package() {
- cd numix-gtk-theme
+ cd numix-gtk-theme-${pkgver}
make SASS="bundle exec sass" DESTDIR="${pkgdir}" install
}