summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrimi2016-04-23 07:01:22 +0200
committergrimi2016-04-23 07:01:22 +0200
commit96010698c6c36462fc7fc2be6cacb21a70992792 (patch)
tree8ea78b307485e63cfbce5ff63a825538680d45a8
parent1c20238bdd9422af5d35f8532533e27aa83330e6 (diff)
downloadaur-96010698c6c36462fc7fc2be6cacb21a70992792.tar.gz
Update: 2.5.1.r210.3c82d31
-rw-r--r--.SRCINFO8
-rw-r--r--Gemfile2
-rw-r--r--PKGBUILD31
3 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 341d35545ac1..c01e681a6e4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Apr 19 16:44:19 UTC 2016
+# Sat Apr 23 05:01:22 UTC 2016
pkgbase = numix-themes-green
pkgdesc = A flat and light theme with a modern look using Green color (GNOME, MATE, Openbox, Unity, XFCE)
- pkgver = 2.5.1.r199.bde0a73
+ pkgver = 2.5.1.r210.3c82d31
pkgrel = 1
url = http://numixproject.org/
arch = any
@@ -11,10 +11,8 @@ pkgbase = numix-themes-green
makedepends = ruby-bundler
makedepends = imagemagick
depends = gtk-engine-murrine
- source = git+https://github.com/shimmerproject/Numix.git#commit=bde0a7364864b0e3b8265c5b13969757295e1e17
- source = Gemfile
+ source = git+https://github.com/numixproject/numix-gtk-theme.git#commit=3c82d31944793e125f54ca443be6d4b01c6a67d7
sha256sums = SKIP
- sha256sums = b1061ba7ce09c9eb3e41f59362aa8c21d27073b0658f13fb5eabdaea654afe2c
pkgname = numix-themes-green
diff --git a/Gemfile b/Gemfile
deleted file mode 100644
index 3f76dd555ee0..000000000000
--- a/Gemfile
+++ /dev/null
@@ -1,2 +0,0 @@
-source "https://rubygems.org"
-gem "sass"
diff --git a/PKGBUILD b/PKGBUILD
index fb9aac7e9aa9..1ac377a58e0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: grimi <grimi at poczta dot fm>
pkgname=numix-themes-green
-pkgver=2.5.1.r199.bde0a73
+pkgver=2.5.1.r210.3c82d31
pkgrel=1
pkgdesc="A flat and light theme with a modern look using Green color (GNOME, MATE, Openbox, Unity, XFCE)"
arch=('any')
@@ -9,21 +9,20 @@ url='http://numixproject.org/'
license=('GPL3')
depends=('gtk-engine-murrine')
makedepends=('git' 'ruby-bundler' 'imagemagick')
-_commit='bde0a7364864b0e3b8265c5b13969757295e1e17'
-source=("git+https://github.com/shimmerproject/Numix.git#commit=${_commit}" "Gemfile")
-sha256sums=('SKIP'
- 'b1061ba7ce09c9eb3e41f59362aa8c21d27073b0658f13fb5eabdaea654afe2c')
+_commit='3c82d31944793e125f54ca443be6d4b01c6a67d7'
+source=("git+https://github.com/numixproject/numix-gtk-theme.git#commit=${_commit}")
+sha256sums=('SKIP')
pkgver() {
- cd Numix
+ cd numix-gtk-theme
git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./'
}
prepare() {
- cd Numix
+ cd numix-gtk-theme
for FILE in gtk-2.0/gtkrc \
gtk-3.0/scss/_global.scss \
gtk-3.0/assets/*.svg \
@@ -37,10 +36,12 @@ prepare() {
unity/*.svg \
index.theme
do
- sed -i 's/#f0544c/#697740/Ig' "${FILE}"
- sed -i 's/#d64937/#697740/Ig' "${FILE}"
- sed -i 's/#f06860/#697740/Ig' "${FILE}"
- sed -i 's/#f44336/#697740/Ig' "${FILE}"
+ sed -i 's/#f0544c/#697740/Ig' "${FILE}"
+ sed -i 's/#d64937/#697740/Ig' "${FILE}"
+ sed -i 's/#f06860/#697740/Ig' "${FILE}"
+ sed -i 's/#f44336/#697740/Ig' "${FILE}"
+ sed -i 's/#444444/#333333/g' "${FILE}"
+ sed -i 's/#444/#333/g' "${FILE}"
sed -i 's/Numix/Numix-Green/I' "${FILE}"
done
@@ -55,20 +56,22 @@ prepare() {
convert -resize 16x16 -background none "${FILE}" "${FILE%.svg}.png"
fi
done
+
+ echo -e "source 'https://rubygems.org'\ngem 'sass'" > Gemfile
}
build() {
- cd Numix
+ cd numix-gtk-theme
bundle install --path .
make SASS="bundle exec sass"
}
package() {
- cd Numix
- install -dm 755 "${pkgdir}"/usr/share/themes/Numix-Green
+ cd numix-gtk-theme
rm -rf .git .gitignore CREDITS LICENSE README.md
+ install -dm 755 "${pkgdir}"/usr/share/themes/Numix-Green
cp -dr --no-preserve='ownership,mode' * "${pkgdir}"/usr/share/themes/Numix-Green
}