summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2019-11-25 16:34:37 -0500
committerStorm Dragon2019-11-25 16:34:37 -0500
commit9236517fbe8dcbe24fa4b616c37a2dcd690ea498 (patch)
tree3efdd7226a458b87df12b698640a9b636cb0705e
downloadaur-9236517fbe8dcbe24fa4b616c37a2dcd690ea498.tar.gz
Initial commit.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD36
-rw-r--r--numnastics.desktop12
-rw-r--r--numnastics.sh5
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..010a994da5bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = numnastics-git
+ pkgdesc = A number puzzle audio game
+ pkgver = r2.3d956cc
+ pkgrel = 1
+ url = https://gitlab.com/stormdragon2976/numnastics
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = python-pygame
+ depends = python-requests
+ depends = python-xdg
+ provides = numnastics
+ conflicts = numnastics
+ source = git+https://gitlab.com/stormdragon2976/numnastics.git
+ source = numnastics.desktop
+ source = numnastics.sh
+ sha512sums = SKIP
+ sha512sums = b45168181aeeca72a8d0e74cf6eff6dd2e7511431f8cf9157b9804445145e170c98328a7216ea27d9a02809bba328935e0f4fe95e519648e8217453749c42bbe
+ sha512sums = 5e7686884116fdca9a58508dee891b6285e1ad7755a505c199024036fad3428514d16ccef3e96ff6803a45d67a7ca618000a3c1733c07028a67ad804a8fbc123
+
+pkgname = numnastics-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c455883c83f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+_pkgname="numnastics"
+pkgname="${_pkgname}-git"
+pkgver=r2.3d956cc
+pkgrel=1
+pkgdesc="A number puzzle audio game"
+arch=('any')
+url="https://gitlab.com/stormdragon2976/numnastics"
+license=('GPL3')
+depends=('python' 'python-pygame' 'python-requests' 'python-xdg')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://gitlab.com/stormdragon2976/numnastics.git"
+ "$_pkgname.desktop"
+ "$_pkgname.sh")
+sha512sums=('SKIP'
+ 'b45168181aeeca72a8d0e74cf6eff6dd2e7511431f8cf9157b9804445145e170c98328a7216ea27d9a02809bba328935e0f4fe95e519648e8217453749c42bbe'
+ '5e7686884116fdca9a58508dee891b6285e1ad7755a505c199024036fad3428514d16ccef3e96ff6803a45d67a7ca618000a3c1733c07028a67ad804a8fbc123')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ install -d "$pkgdir/opt/numnastics"
+ cp -a * "$pkgdir/opt/numnastics"
+
+ install -Dm755 "$srcdir/$_pkgname.sh" "$pkgdir/usr/bin/$_pkgname"
+
+ install -Dm644 "$srcdir/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/numnastics.desktop b/numnastics.desktop
new file mode 100644
index 000000000000..40fc47c06fa6
--- /dev/null
+++ b/numnastics.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Encoding=UTF-8
+Name=Numnastics
+GenericName=A number puzzle audio game
+Comment=A number puzzle audio game
+Path=/opt/numnastics
+Exec=python numnastics
+Terminal=false
+StartupNotify=true
+Categories=Application;Game;PuzzleGame
diff --git a/numnastics.sh b/numnastics.sh
new file mode 100644
index 000000000000..7d8e3005662a
--- /dev/null
+++ b/numnastics.sh
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+cd /opt/numnastics
+python numnastics
+exit 0