summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2015-07-06 10:49:30 +0200
committerAdrian Perez de Castro2015-07-06 10:49:30 +0200
commit6166866e2e090cd52c127bc14aae928235e8b362 (patch)
tree6760ac79dc14b283b616e826fc6098270e905edc
parentb5bfd209b5a43b4e6ffd689a9b99a487a24be7db (diff)
downloadaur-6166866e2e090cd52c127bc14aae928235e8b362.tar.gz
Update dependencies, call gtk-update-icon-cache in install script
- Newer versions of Nuntius require libqrencode, so this adds qrencode in depends. Also added gtk3 now that it is used. - Removed pre_upgrade() function in install script (which is unneeded for this package). - Added a missing call to gtk-update-icon-cache in the install script.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--nuntius.install9
3 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d02275a6c24..8889429ef461 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nuntius-git
pkgdesc = Delivers notifications from your phone or tablet to your computer
- pkgver = r30.85c3552
+ pkgver = r69.ebc54c1
pkgrel = 1
url = https://github.com/holylobster/nuntius-linux
install = nuntius.install
@@ -11,11 +11,12 @@ pkgbase = nuntius-git
makedepends = intltool
depends = json-glib
depends = desktop-file-utils
- depends = gtk-update-icon-cache
+ depends = qrencode
+ depends = gtk3
source = nuntius-git::git://github.com/holylobster/nuntius-linux
source = nuntius.install
sha512sums = SKIP
- sha512sums = 6dabcff8c668d4f7585677bc896b06b6eee506765016fbd3220000ab352a90ba49d14bfdc7082278274f99d9b0fbaf1e6921c330ed5cfca7e765ab04b896f2d1
+ sha512sums = b5b76afd64c3f0dcac7e20a24306a5af5f10635079320130f40281c0065dd0c7a5a2dc124a8086b0f9ebf601b7e5e137167faaa43b69b83a4c64d114f5713c37
pkgname = nuntius-git
diff --git a/PKGBUILD b/PKGBUILD
index 79a6e2b50bb6..ff874b6bae87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@ pkgname='nuntius-git'
pkgdesc='Delivers notifications from your phone or tablet to your computer'
url='https://github.com/holylobster/nuntius-linux'
license=('GPL')
-pkgver=r30.85c3552
+pkgver=r69.ebc54c1
pkgrel=1
arch=('x86_64' 'i686')
makedepends=('vala' 'intltool')
-depends=('json-glib' 'desktop-file-utils' 'gtk-update-icon-cache')
+depends=('json-glib' 'desktop-file-utils' 'qrencode' 'gtk3')
source=("${pkgname}::git://github.com/holylobster/nuntius-linux"
nuntius.install)
sha512sums=('SKIP'
- '6dabcff8c668d4f7585677bc896b06b6eee506765016fbd3220000ab352a90ba49d14bfdc7082278274f99d9b0fbaf1e6921c330ed5cfca7e765ab04b896f2d1')
+ 'b5b76afd64c3f0dcac7e20a24306a5af5f10635079320130f40281c0065dd0c7a5a2dc124a8086b0f9ebf601b7e5e137167faaa43b69b83a4c64d114f5713c37')
install='nuntius.install'
diff --git a/nuntius.install b/nuntius.install
index 3d7190d48cf2..a1f86983fb8c 100644
--- a/nuntius.install
+++ b/nuntius.install
@@ -1,16 +1,11 @@
#! /bin/sh
post_install () {
- glib-compile-schemas /usr/share/glib-2.0/schemas
+ gtk-update-icon-cache /usr/share/icons/hicolor/
+ glib-compile-schemas /usr/share/glib-2.0/schemas
update-desktop-database -q
}
-pre_upgrade() {
- if [ -f /usr/share/gconf/schemas/gedit.schemas ]; then
- gconfpkg --uninstall gedit
- fi
-}
-
post_upgrade() {
post_install $1
}