summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2015-03-06 18:07:28 +0100
committerAdrian Perez de Castro2015-06-13 18:16:54 +0200
commite78c31fa21bcef00305f7b9251b08c3e27464977 (patch)
treef399b86cc7c605f0a02236e029afb0d61a3f5ec1
downloadaur-e78c31fa21bcef00305f7b9251b08c3e27464977.tar.gz
nuntius-git: Added
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rw-r--r--nuntius.install20
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe7e35e4029f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nuntius-git
+ pkgdesc = Delivers notifications from your phone or tablet to your computer
+ pkgver = r2.27ac01b
+ pkgrel = 1
+ url = https://github.com/holylobster/nuntius-linux
+ install = nuntius.install
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = json-glib
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ source = nuntius-git::git://github.com/holylobster/nuntius-linux
+ source = nuntius.install
+ sha512sums = SKIP
+ sha512sums = 6dabcff8c668d4f7585677bc896b06b6eee506765016fbd3220000ab352a90ba49d14bfdc7082278274f99d9b0fbaf1e6921c330ed5cfca7e765ab04b896f2d1
+
+pkgname = nuntius-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d24bf2a7c036
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
+pkgname='nuntius-git'
+pkgdesc='Delivers notifications from your phone or tablet to your computer'
+url='https://github.com/holylobster/nuntius-linux'
+license=('GPL')
+pkgver=r11.d40448b
+pkgrel=1
+arch=('x86_64' 'i686')
+makedepends=('vala' 'autoconf' 'automake')
+depends=('json-glib' 'desktop-file-utils' 'gtk-update-icon-cache')
+source=("${pkgname}::git://github.com/holylobster/nuntius-linux"
+ nuntius.install)
+sha512sums=('SKIP'
+ '6dabcff8c668d4f7585677bc896b06b6eee506765016fbd3220000ab352a90ba49d14bfdc7082278274f99d9b0fbaf1e6921c330ed5cfca7e765ab04b896f2d1')
+install='nuntius.install'
+
+
+pkgver () {
+ cd "${pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+
+build () {
+ cd "${pkgname}"
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+
+package () {
+ cd "${pkgname}"
+ make install DESTDIR="${pkgdir}"
+}
diff --git a/nuntius.install b/nuntius.install
new file mode 100644
index 000000000000..3d7190d48cf2
--- /dev/null
+++ b/nuntius.install
@@ -0,0 +1,20 @@
+#! /bin/sh
+
+post_install () {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ update-desktop-database -q
+}
+
+pre_upgrade() {
+ if [ -f /usr/share/gconf/schemas/gedit.schemas ]; then
+ gconfpkg --uninstall gedit
+ fi
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}