summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredtide2016-05-20 12:13:42 +0200
committerredtide2016-05-20 12:13:42 +0200
commit43210577c9feb51e076a392f23dc677804e692b6 (patch)
treed28cfc02d3e4742b960bba079164fb30c85dd87f
downloadaur-43210577c9feb51e076a392f23dc677804e692b6.tar.gz
First commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--nuovext-icon-theme.install11
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a67db984d4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nuovext-icon-theme
+ pkgdesc = nuoveXT2 icon theme
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/redtide/nuovext-icon-theme
+ install = nuovext-icon-theme.install
+ arch = any
+ license = GPL
+ depends = gtk-update-icon-cache
+ source = git://github.com/redtide/nuovext-icon-theme.git
+ md5sums = SKIP
+
+pkgname = nuovext-icon-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0705c6adf51a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: RedTide
+pkgname=nuovext-icon-theme
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="nuoveXT2 icon theme"
+arch=('any')
+url="https://github.com/redtide/nuovext-icon-theme"
+license=('GPL')
+depends=('gtk-update-icon-cache')
+install=nuovext-icon-theme.install
+source=(git://github.com/redtide/nuovext-icon-theme.git)
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}
diff --git a/nuovext-icon-theme.install b/nuovext-icon-theme.install
new file mode 100644
index 000000000000..b53df2cca658
--- /dev/null
+++ b/nuovext-icon-theme.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/nuoveXT23
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}