summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBumsik Kim2019-11-28 02:04:19 +0900
committerBumsik Kim2019-11-28 02:04:19 +0900
commit5765dcb21feb8bd769e9f48ba02e924a9b15de9b (patch)
treec7b0011293626054dd80b15510b0aafaf11c29ad
parent75dd5cda07d3fff89273bdbad826fecc47295df6 (diff)
downloadaur-5765dcb21feb8bd769e9f48ba02e924a9b15de9b.tar.gz
updated: 0.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cbdefdc4dc6..b23c8ebbbed5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nushell
pkgdesc = A shell for the GitHub era
- pkgver = 0.5.0
- pkgrel = 2
+ pkgver = 0.6.0
+ pkgrel = 1
url = http://nushell.sh
arch = i686
arch = x86_64
@@ -14,8 +14,8 @@ pkgbase = nushell
depends = e2fsprogs
optdepends = libxcb
optdepends = libx11
- source = nushell-0.5.0.tar.gz::https://github.com/nushell/nushell/archive/0_5_0.tar.gz
- sha256sums = 46c9c0ba95c464c70c8a4c099962873e5baa1b9bee3413645a0cc245701047da
+ source = nushell-0.6.0.tar.gz::https://github.com/nushell/nushell/archive/0.6.0.tar.gz
+ sha256sums = 90cdd83410d23e32fd47457d227b00cb2c8f607ac38020360eea0e385b693707
pkgname = nushell
diff --git a/PKGBUILD b/PKGBUILD
index 2744d690bd98..9ba2f1b5ba1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,29 @@
pkgname=nushell
cargoname=nu
-pkgver=0.5.0
-pkgver_underscore=0_5_0
-pkgrel=2
+pkgver=0.6.0
+pkgrel=1
makedepends=('rustup')
depends=('openssl' 'zlib' 'e2fsprogs')
optdepends=('libxcb' 'libx11')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
pkgdesc="A shell for the GitHub era"
-source=("$pkgname-$pkgver.tar.gz::https://github.com/nushell/nushell/archive/$pkgver_underscore.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/nushell/nushell/archive/$pkgver.tar.gz")
url="http://nushell.sh"
license=('MIT')
-sha256sums=('46c9c0ba95c464c70c8a4c099962873e5baa1b9bee3413645a0cc245701047da')
+sha256sums=('90cdd83410d23e32fd47457d227b00cb2c8f607ac38020360eea0e385b693707')
build() {
return 0
}
package() {
- cd "$pkgname-$pkgver_underscore"
+ cd "$pkgname-$pkgver"
- cargo +beta install \
+ cargo install \
--all-features \
--locked \
--root "${pkgdir}"/usr \
- --path "./" \
- || ( >&2 echo $'\nInstall Cargo Beta compiler:'\
- $'\n\n\trustup install beta (no root required)'\
- $'\n\nThen try building nushell again.'\
- && false )
+ --path "./"
}