summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-06-13 19:13:37 +0200
committerGoliathLabs2020-06-13 19:13:37 +0200
commit773dec7f1279f521f0ab3b7f1a68168547128ecc (patch)
treedcf94505cc0d8f12fedb2ac74facf3da2f61891a
parent918f641f648ee24a4dcc66d1b2fb08e02fb1ab9a (diff)
downloadaur-773dec7f1279f521f0ab3b7f1a68168547128ecc.tar.gz
Updated: 0.15.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
2 files changed, 18 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d56e91a28f0..ec6298534b41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = nushell
pkgdesc = A new type of shell.
pkgver = 0.15.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.nushell.sh
- arch = any
+ arch = x86_64
+ arch = i686
license = MIT
makedepends = rust
- makedepends = cargo
- makedepends = python
depends = openssl
- depends = zlib
- depends = e2fsprogs
optdepends = libxcb
optdepends = libx11
- source = nushell-0.15.0.tar.gz::https://github.com/nushell/nushell/archive/0.15.0.tar.gz
+ source = https://github.com/nushell/nushell/archive/0.15.0.tar.gz
sha256sums = f19e580b645ff047e3b7cb2e0823654e020cd5c62b22e601caf6be579204dc2a
pkgname = nushell
diff --git a/PKGBUILD b/PKGBUILD
index d9203d4a6f7a..519303c86431 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,27 @@
_pkgname=nu
pkgname=${_pkgname}shell
pkgver=0.15.0
-pkgrel=1
+pkgrel=2
pkgdesc="A new type of shell."
-arch=('any')
url="https://www.nushell.sh"
license=('MIT')
-depends=('openssl' 'zlib' 'e2fsprogs')
-makedepends=('rust' 'cargo' 'python')
+makedepends=('rust')
+depends=('openssl')
optdepends=('libxcb' 'libx11')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/nushell/nushell/archive/$pkgver.tar.gz")
+arch=('x86_64' 'i686')
+source=("https://github.com/nushell/nushell/archive/$pkgver.tar.gz")
# Use updpkgsums to update the checksum
sha256sums=('f19e580b645ff047e3b7cb2e0823654e020cd5c62b22e601caf6be579204dc2a')
-build() {
- cd "$pkgname-$pkgver"
- cargo build \
- --locked \
- --features=stable \
- --release
-}
-
package() {
- cd "$pkgname-$pkgver"
- install -d "$pkgdir/usr/bin"
- find target/release \
- -maxdepth 1 \
- -executable \
- -type f \
- -exec install -m 755 "{}" "$pkgdir"/usr/bin \;
+ cd "$srcdir/$pkgver"
+
+ cargo install \
+ --locked \
+ --path . \
+ --features stable \
+ --root "${pkgdir}"/usr
+
+ rm -f "${pkgdir}"/usr/.crate*
}