summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-06-11 13:33:21 +0200
committerGoliathLabs2020-06-11 13:33:21 +0200
commit918f641f648ee24a4dcc66d1b2fb08e02fb1ab9a (patch)
treeeb3f5730fde830d44b0e9b47bdbe4130230ecd1c
parent92c2a060c0a762d91a27c085af69949a364e08f6 (diff)
downloadaur-918f641f648ee24a4dcc66d1b2fb08e02fb1ab9a.tar.gz
Updated: 0.15.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67d8b7b4a024..6d56e91a28f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,9 @@
pkgbase = nushell
- pkgdesc = A shell for the GitHub era
- pkgver = 0.14.0
+ pkgdesc = A new type of shell.
+ pkgver = 0.15.0
pkgrel = 1
- url = http://nushell.sh
- arch = i686
- arch = x86_64
- arch = armv6h
- arch = armv7h
- arch = aarch64
+ url = https://www.nushell.sh
+ arch = any
license = MIT
makedepends = rust
makedepends = cargo
@@ -17,8 +13,8 @@ pkgbase = nushell
depends = e2fsprogs
optdepends = libxcb
optdepends = libx11
- source = nushell-0.14.0.tar.gz::https://github.com/nushell/nushell/archive/0.14.0.tar.gz
- sha256sums = 8084bb21433aa3598475470abf78e6653440b51db2f28392212eee00238c3346
+ source = nushell-0.15.0.tar.gz::https://github.com/nushell/nushell/archive/0.15.0.tar.gz
+ sha256sums = f19e580b645ff047e3b7cb2e0823654e020cd5c62b22e601caf6be579204dc2a
pkgname = nushell
diff --git a/PKGBUILD b/PKGBUILD
index f705a166301b..d9203d4a6f7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
# Contributor: Bumsik Kim <k.bumsik@gmail.com>
# Scripts inspired by nushell-git package
-pkgname=nushell
-cargoname=nu
-pkgver=0.14.0
+_pkgname=nu
+pkgname=${_pkgname}shell
+pkgver=0.15.0
pkgrel=1
-makedepends=('rust' 'cargo' 'python')
+pkgdesc="A new type of shell."
+arch=('any')
+url="https://www.nushell.sh"
+license=('MIT')
depends=('openssl' 'zlib' 'e2fsprogs')
+makedepends=('rust' 'cargo' 'python')
optdepends=('libxcb' 'libx11')
-arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
-pkgdesc="A shell for the GitHub era"
source=("$pkgname-$pkgver.tar.gz::https://github.com/nushell/nushell/archive/$pkgver.tar.gz")
-url="http://nushell.sh"
-license=('MIT')
# Use updpkgsums to update the checksum
-sha256sums=('8084bb21433aa3598475470abf78e6653440b51db2f28392212eee00238c3346')
+sha256sums=('f19e580b645ff047e3b7cb2e0823654e020cd5c62b22e601caf6be579204dc2a')
build() {
cd "$pkgname-$pkgver"