summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2020-10-19 02:44:06 +0200
committerKokaKiwi2020-10-19 02:44:06 +0200
commita92cfca0cbc77e0249907df670f3b047b5d0d984 (patch)
tree0a049e61dcab08ed5c6199120731972b236ded95
parent8b50b02d0fa2a1bbebbebacf07b883354eb5eaf8 (diff)
downloadaur-a92cfca0cbc77e0249907df670f3b047b5d0d984.tar.gz
Update to 0.21.0 and build with extra feature (making it features-equal to nushell-bin)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
-rw-r--r--nushell.install14
3 files changed, 35 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b039be57d040..e522ed426bd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = nushell
pkgdesc = A new type of shell.
- pkgver = 0.20.0
+ pkgver = 0.21.0
pkgrel = 1
url = https://www.nushell.sh
+ install = nushell.install
arch = x86_64
arch = i686
license = MIT
makedepends = rust
depends = openssl
- optdepends = libxcb
- optdepends = libx11
- source = https://github.com/nushell/nushell/archive/0.20.0.tar.gz
- sha256sums = ccecbfd49d03ca45f347fe55b789b8732003ceab49a14af110390e723f2fd274
- b2sums = 3d8fcccc0c353ab7c98a4ad5c3485cd74950d96c481cb6b855e8d5f549b3622d28d1e32f087eb6f620f83f1b7160d25efe80255694cad79b23ad5c2585c5678a
+ depends = libxcb
+ depends = libgit2
+ depends = zlib
+ optdepends = libx11: for binaryview plugin
+ source = https://github.com/nushell/nushell/archive/0.21.0.tar.gz
+ sha256sums = 24598bcf6e61825fd3b6f17e083952926a4b072efff413748bbd5bc83a3158f1
+ b2sums = b09cf833353b302479238f938a92979a6d37cb4072a945a5abbf637757c5083ccc59906ba7527bfcad5e6bf89eb9eecafc94a263597934720950833e4516bffd
pkgname = nushell
- install = nushell.install
diff --git a/PKGBUILD b/PKGBUILD
index 7f4eaae175ee..821a685a6240 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,33 @@
-# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Maintainer: KokaKiwi <kokakiwi+aur@kokakiwi.net>
+# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Bumsik Kim <k.bumsik@gmail.com>
-# Contributor: KokaKiwi <kokakiwi+aur@kokakiwi.net>
-# Scripts inspired by nushell-git package
-_pkgname=nu
-pkgname=${_pkgname}shell
-pkgver=0.20.0
+pkgname=nushell
+pkgver=0.21.0
pkgrel=1
pkgdesc="A new type of shell."
url="https://www.nushell.sh"
license=('MIT')
+depends=('openssl' 'libxcb' 'libgit2' 'zlib')
+optdepends=('libx11: for binaryview plugin')
makedepends=('rust')
-depends=('openssl')
-optdepends=('libxcb' 'libx11')
arch=('x86_64' 'i686')
-source=("https://github.com/nushell/nushell/archive/$pkgver.tar.gz")
-# Use updpkgsums to update the checksum
-sha256sums=('ccecbfd49d03ca45f347fe55b789b8732003ceab49a14af110390e723f2fd274')
-b2sums=('3d8fcccc0c353ab7c98a4ad5c3485cd74950d96c481cb6b855e8d5f549b3622d28d1e32f087eb6f620f83f1b7160d25efe80255694cad79b23ad5c2585c5678a')
+source=("https://github.com/nushell/nushell/archive/${pkgver}.tar.gz")
+install=nushell.install
+sha256sums=('24598bcf6e61825fd3b6f17e083952926a4b072efff413748bbd5bc83a3158f1')
+b2sums=('b09cf833353b302479238f938a92979a6d37cb4072a945a5abbf637757c5083ccc59906ba7527bfcad5e6bf89eb9eecafc94a263597934720950833e4516bffd')
-package() {
- install=nushell.install
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ cargo build --release --locked --features extra
+}
- cd "$srcdir/$pkgname-$pkgver"
+package() {
+ cd "${pkgname}-${pkgver}"
- cargo install \
- --locked \
- --path . \
- --features stable \
- --root "${pkgdir}"/usr
+ install -Dm0755 -t "${pkgdir}/usr/bin" \
+ target/release/nu $(find target/release -maxdepth 1 -type f -executable -name 'nu_plugin_*')
- rm -f "${pkgdir}"/usr/.crate*
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/nushell.install b/nushell.install
index 1e911204aaf5..0e488b880ed0 100644
--- a/nushell.install
+++ b/nushell.install
@@ -1,13 +1,11 @@
-
post_install() {
- grep -qe '^/usr/bin/nu$' etc/shells || echo '/usr/bin/nu' >> etc/shells
- }
+ grep -qe '^/usr/bin/nu$' etc/shells || echo '/usr/bin/nu' >> etc/shells
+}
post_upgrade() {
- post_install
- }
+ post_install
+}
pre_remove() {
- sed -i -r '/^\/usr\/bin\/nu$/d' etc/shells
- }
-
+ sed -i -r '/^\/usr\/bin\/nu$/d' etc/shells
+}