summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBumsik Kim2019-10-16 20:53:25 +0900
committerBumsik Kim2019-10-16 20:53:25 +0900
commitef32cb52638db561b3862a7d76f199944ea67448 (patch)
tree6a145c21529f72cfc7c454c3806d427837a3a330
parent80e071e0e87e7915ed5a69b619328840b6e5ae64 (diff)
downloadaur-ef32cb52638db561b3862a7d76f199944ea67448.tar.gz
Updated: 0.4.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c173d61bbf1..569c709b8d9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = nushell
pkgdesc = A shell for the GitHub era
- pkgver = 0.3.0
- pkgrel = 4
+ pkgver = 0.4.0
+ pkgrel = 1
url = http://nushell.sh
arch = i686
arch = x86_64
arch = armv6h
arch = armv7h
license = MIT
- makedepends = rust-nightly
- makedepends = cargo
+ makedepends = rustup
depends = openssl
depends = zlib
optdepends = libxcb
optdepends = libx11
- source = nushell-0.3.0.tar.gz::https://github.com/nushell/nushell/archive/0.3.0.tar.gz
- sha256sums = 0151f1a09b76c83b7e20932e5e3b0d3af41d32a7862e070ef1b3d5f1163b2876
+ source = nushell-0.4.0.tar.gz::https://github.com/nushell/nushell/archive/0.4.0.tar.gz
+ sha256sums = 7111d3067db3dabc6137e8a441670de0fae63deae522d1675fc77402948f2c67
pkgname = nushell
diff --git a/PKGBUILD b/PKGBUILD
index 84c818665310..ec41f9e64ea5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgname=nushell
cargoname=nu
-pkgver=0.3.0
-pkgrel=4
-makedepends=('rust-nightly' 'cargo')
+pkgver=0.4.0
+pkgrel=1
+makedepends=('rustup')
depends=('openssl' 'zlib')
optdepends=('libxcb' 'libx11')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -13,7 +13,7 @@ pkgdesc="A shell for the GitHub era"
source=("$pkgname-$pkgver.tar.gz::https://github.com/nushell/nushell/archive/$pkgver.tar.gz")
url="http://nushell.sh"
license=('MIT')
-sha256sums=('0151f1a09b76c83b7e20932e5e3b0d3af41d32a7862e070ef1b3d5f1163b2876')
+sha256sums=('7111d3067db3dabc6137e8a441670de0fae63deae522d1675fc77402948f2c67')
build() {
return 0
@@ -22,12 +22,14 @@ build() {
package() {
cd "$pkgname-$pkgver"
- cargo +nightly install \
- --no-track \
- --locked \
+ cargo +beta install \
--all-features \
+ --locked \
--root "${pkgdir}"/usr \
--path "./" \
- -Z install-upgrade
+ || ( >&2 echo $'\nInstall Cargo Beta compiler:'\
+ $'\n\n\trustup install beta (no root required)'\
+ $'\n\nThen try building nushell again.'\
+ && false )
}