summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBumsik Kim2019-08-26 09:33:45 +0900
committerBumsik Kim2019-08-26 09:33:45 +0900
commitff9077b3f7f47a202a3e05481f467fa4aefc561e (patch)
tree383c1714e478bdf598ecc96515cd11a7d1c6fcd4
downloadaur-ff9077b3f7f47a202a3e05481f467fa4aefc561e.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..585e8000912a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = nushell
+ pkgdesc = A shell for the GitHub era
+ pkgver = 0.2.0
+ pkgrel = 4
+ url = http://nushell.sh
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = rust-nightly
+ makedepends = cargo
+ depends = openssl
+ depends = zlib
+ optdepends = libxcb
+ optdepends = libx11
+ source = nushell-0.2.0.tar.gz::https://github.com/nushell/nushell/archive/0.2.0.tar.gz
+ sha256sums = 5bce8cdb33a6580ff15214322bc66945c0b4d93375056865ad30e0415fece3de
+
+pkgname = nushell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08402276302d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Bumsik Kim <k.bumsik@gmail.com>
+# Scripts inspired by nushell-git package
+
+pkgname=nushell
+cargoname=nu
+pkgver=0.2.0
+pkgrel=4
+makedepends=('rust-nightly' 'cargo')
+depends=('openssl' 'zlib')
+optdepends=('libxcb' 'libx11')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="A shell for the GitHub era"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/nushell/nushell/archive/$pkgver.tar.gz")
+url="http://nushell.sh"
+license=('MIT')
+sha256sums=('5bce8cdb33a6580ff15214322bc66945c0b4d93375056865ad30e0415fece3de')
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ cargo +nightly install \
+ --no-track \
+ --locked \
+ --features rawkey,clipboard \
+ --root "${pkgdir}"/usr \
+ --path "./" \
+ -Z install-upgrade
+}
+