summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-03-11 23:25:31 +0300
committerCaleb Maclennan2023-03-11 23:25:31 +0300
commit0abe48b0ed2db36c246478b72735abe78040a6b7 (patch)
tree7494cc0cf1cf6314331f10c593dbf11083abf68b
parente82b3bb102e604fd0aae552ded6c5acde09849b8 (diff)
downloadaur-0abe48b0ed2db36c246478b72735abe78040a6b7.tar.gz
upgpkg: nushell-git 0.76.0.r124.g7e82f8d-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD71
2 files changed, 50 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12a7bd65cdc9..0cff315b8a01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
pkgbase = nushell-git
pkgdesc = A new type of shell
- pkgver = 0.15.0.r2.ga268e825
+ pkgver = 0.76.0.r124.g7e82f8d
pkgrel = 1
url = https://www.nushell.sh
- arch = i686
arch = x86_64
+ arch = i686
arch = armv6h
arch = armv7h
license = MIT
- makedepends = rust
- makedepends = cargo
- makedepends = python
makedepends = git
+ makedepends = cargo
depends = openssl
depends = zlib
- depends = e2fsprogs
- depends = libx11
depends = curl
optdepends = libxcb
+ provides = nushell=0.76.0.r124.g7e82f8d
conflicts = nushell
- source = nushell-git::git+https://github.com/nushell/nushell.git
+ source = nushell::git+https://github.com/nushell/nushell.git
sha256sums = SKIP
pkgname = nushell-git
diff --git a/PKGBUILD b/PKGBUILD
index c6a4bcb48b26..3150fafd1904 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,62 @@
# Maintainer: Flaviu Tamas <me@flaviutamas.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: Felix Golatofski <contact@xdfr.de>
+# Upstream tests have multiple issues including race conditions, using external
+# binaries, differing results based on unrelated system directories, etc.
+# See https://github.com/nushell/nushell/issues/7951
+# See https://github.com/nushell/nushell/issues/8404
+BUILDENV+=(!check)
+
_pkgname=nushell
pkgname=$_pkgname-git
-pkgver=0.60.0.r50.ga2872b4cc
+pkgver=0.76.0.r124.g7e82f8d
pkgrel=1
-makedepends=('rust' 'cargo' 'python' 'git')
-# libx11 required for stable preset
-depends=('openssl' 'zlib' 'e2fsprogs' 'libx11' 'curl')
-optdepends=('libxcb')
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-pkgdesc="A new type of shell"
-source=("$pkgname::git+https://github.com/nushell/nushell.git")
-url="https://www.nushell.sh"
+pkgdesc='A new type of shell'
+arch=('x86_64' 'i686' 'armv6h' 'armv7h')
+url='https://www.nushell.sh'
+_url="https://github.com/$_pkgname/$_pkgname"
license=('MIT')
+depends=('openssl' 'zlib' 'curl')
+optdepends=('libxcb')
+makedepends=('git' 'cargo')
+conflicts=("$_pkgname")
+provides=("$_pkgname=$pkgver")
+source=("${pkgname%-git}::git+$_url.git")
sha256sums=('SKIP')
-conflicts=('nushell')
-build() {
- return 0
+prepare() {
+ cd "${pkgname%-git}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
pkgver() {
- cd "$srcdir/$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname%-git}"
+ git describe --long --abbrev=7 --tags HEAD |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
- case "$CFLAGS" in *"-g"*) export RUSTFLAGS="-g";; esac
- cd "$srcdir/$pkgname"
-
- # user may not be using rustup, so always succeed
- rustup override set stable || true
+build() {
+ cd "${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --frozen --workspace --features=extra,dataframe
+}
- cargo install \
- --locked \
- --path . \
- --features stable \
- --root="$pkgdir/usr"
+check() {
+ cd "${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --workspace --features=extra,dataframe
+}
- rm "$pkgdir/usr/.crates.toml" "$pkgdir/usr/.crates2.json"
+package() {
+ cd "${pkgname%-git}"
+ find target/release \
+ -maxdepth 1 \
+ -executable \
+ -type f \
+ -name "nu*" \
+ -exec install -Dm0755 -t "$pkgdir/usr/bin/" {} +
+ install -Dm0644 -t "$pkgdir/usr/share/doc/$pkgname/" README.md
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}