summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-03-14 12:34:03 +0300
committerCaleb Maclennan2023-03-14 12:34:03 +0300
commit1446d7ac62c250291539b30d492878515e5306d9 (patch)
tree39a9787dcb2a9bd0d0365a094fa8a1505571cbf2
parent5a9693bd223c23781d4bb57fac9da9e4d3516195 (diff)
downloadaur-1446d7ac62c250291539b30d492878515e5306d9.tar.gz
upgpkg: nushell-git 0.76.0.r134.gc7583ec-2
Bring back some LTO action
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 003bba4b66bb..9bed4632966b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nushell-git
pkgdesc = A new type of shell
pkgver = 0.76.0.r134.gc7583ec
- pkgrel = 1
+ pkgrel = 2
url = https://www.nushell.sh
install = nushell.install
arch = x86_64
@@ -17,7 +17,6 @@ pkgbase = nushell-git
depends = bzip2
provides = nushell=0.76.0.r134.gc7583ec
conflicts = nushell
- options = !lto
source = nushell::git+https://github.com/nushell/nushell.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4a5a46a34711..f32cebc3ba4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ BUILDENV+=(!check)
_pkgname=nushell
pkgname=$_pkgname-git
pkgver=0.76.0.r134.gc7583ec
-pkgrel=1
+pkgrel=2
pkgdesc='A new type of shell'
arch=('x86_64' 'i686' 'armv6h' 'armv7h')
url='https://www.nushell.sh'
@@ -21,7 +21,6 @@ depends=('openssl' 'libxcb' 'curl' 'bzip2')
makedepends=('git' 'cargo')
conflicts=("$_pkgname")
provides=("$_pkgname=$pkgver")
-options=('!lto')
install=nushell.install
source=("${pkgname%-git}::git+$_url.git")
sha256sums=('SKIP')
@@ -41,6 +40,7 @@ build() {
cd "${pkgname%-git}"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
+ CFLAGS+=" -ffat-lto-objects"
cargo build --release --frozen --workspace --features=extra,dataframe
}