summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlaviu Tamas2020-06-11 14:30:55 -0400
committerFlaviu Tamas2020-06-11 14:43:02 -0400
commit43fa695742b30cb7b3c7620a92a76655d1ab31fc (patch)
tree1fabbbfe16146a183d058b36d0e2045f78add86c
parent6565849779e98631d1a49585919e027159866f3e (diff)
downloadaur-43fa695742b30cb7b3c7620a92a76655d1ab31fc.tar.gz
Update pkgbuild
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD36
3 files changed, 31 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e84148b9db21..e59a6dee3ce8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = nushell-git
- pkgdesc = A shell for the GitHub era
- pkgver = r2093.906d0b92
+ pkgdesc = A new type of shell
+ pkgver = 0.15.0.r2.ga268e825
pkgrel = 1
- url = http://nushell.sh
+ url = https://www.nushell.sh
arch = i686
arch = x86_64
arch = armv6h
@@ -11,12 +11,14 @@ pkgbase = nushell-git
makedepends = rust
makedepends = cargo
makedepends = python
+ makedepends = git
depends = openssl
depends = zlib
depends = e2fsprogs
+ depends = libx11
+ depends = curl
optdepends = libxcb
- optdepends = libx11
- source = nushell-git::git+https://github.com/nushell/nushell
+ source = nushell-git::git+https://github.com/nushell/nushell.git
sha256sums = SKIP
pkgname = nushell-git
diff --git a/.gitignore b/.gitignore
index 3c94091fcd4b..b511b6da3889 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,5 @@
/pkg
/src
nushell-git/
+chroot/
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 5c3d73f470cf..4bc7a7bbe8b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,18 @@
# Maintainer: Flaviu Tamas <me@flaviutamas.com>
-pkgname=nushell-git
-pkgver=r2093.906d0b92
+# Contributor: Felix Golatofski <contact@xdfr.de>
+
+_pkgname=nushell
+pkgname=$_pkgname-git
+pkgver=0.15.0.r2.ga268e825
pkgrel=1
-makedepends=('rust' 'cargo' 'python')
-depends=('openssl' 'zlib' 'e2fsprogs')
-optdepends=('libxcb' 'libx11')
+makedepends=('rust' 'cargo' 'python' 'git')
+# libx11 required for stable preset
+depends=('openssl' 'zlib' 'e2fsprogs' 'libx11' 'curl')
+optdepends=('libxcb')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-pkgdesc="A shell for the GitHub era"
-source=("$pkgname::git+https://github.com/nushell/nushell")
-url="http://nushell.sh"
+pkgdesc="A new type of shell"
+source=("$pkgname::git+https://github.com/nushell/nushell.git")
+url="https://www.nushell.sh"
license=('MIT')
sha256sums=('SKIP')
@@ -18,17 +22,21 @@ build() {
pkgver() {
cd "$srcdir/$pkgname"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
case "$CFLAGS" in *"-g"*) export RUSTFLAGS="-g";; esac
cd "$srcdir/$pkgname"
+
# user may not be using rustup, so always succeed
rustup override set stable || true
- cargo install --root="$pkgdir/usr" --path=. --locked --features stable
- rm "$pkgdir/usr/.crates.toml"
+
+ cargo install \
+ --locked \
+ --path . \
+ --features stable \
+ --root="$pkgdir/usr"
+
+ rm "$pkgdir/usr/.crates.toml" "$pkgdir/usr/.crates2.json"
}