summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlaviu Tamas2019-08-23 20:03:45 -0400
committerFlaviu Tamas2019-08-23 20:03:45 -0400
commit4864bc17fa363b961320ac9e5dbd76623b3cef5e (patch)
treebf081bf418567ff013150366c81b3f2bbb5dc320
parente6ff0e2f0ee43f192be15e4ba089cf01aa186c23 (diff)
downloadaur-4864bc17fa363b961320ac9e5dbd76623b3cef5e.tar.gz
Conditionally compile with debug symbols
this saves quite a bit of space if they're not wanted
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f171b14631ad..3c9042a18bd2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nushell-git
pkgdesc = A shell for the GitHub era
pkgver = r702.cd1e16d
- pkgrel = 1
+ pkgrel = 3
url = http://nushell.sh
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 28a7f033dfd2..4e3a3597b29b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Flaviu Tamas <me@flaviutamas.com>
pkgname=nushell-git
pkgver=r702.cd1e16d
-pkgrel=1
+pkgrel=3
makedepends=('rust-nightly' 'cargo')
depends=('openssl' 'zlib')
optdepends=('libxcb' 'libx11')
@@ -25,7 +25,8 @@ pkgver() {
}
package() {
+ case "$CFLAGS" in *"-g"*) export RUSTFLAGS="-g";; esac
cd "$srcdir/$pkgname"
- RUSTFLAGS="-g" cargo install --root="$pkgdir/usr" --path=. --locked
+ cargo install --root="$pkgdir/usr" --path=. --locked
rm "$pkgdir/usr/.crates.toml"
}