summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Szczuczko2015-11-23 19:23:20 +0000
committerAlex Szczuczko2015-11-23 19:23:20 +0000
commit64436ed5bde604188cf43b8ba657f4238f48ea81 (patch)
tree93950c6a29a176623a0659f5a649aaa4cc8a7ebb
parentb9eac281f4942cfed71bd83db48a288ec3b0718d (diff)
downloadaur-64436ed5bde604188cf43b8ba657f4238f48ea81.tar.gz
Update to version 2.6.0
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD47
3 files changed, 20 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ed0e6b302df..8e1c7d2b738c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = nusmv
pkgdesc = A new symbolic model checker
- pkgver = 2.5.4
- pkgrel = 3
+ pkgver = 2.6.0
+ pkgrel = 1
url = http://nusmv.irst.itc.it/NuSMV/
arch = i686
arch = x86_64
license = LGPL2.1
+ makedepends = cmake
+ makedepends = python2
makedepends = ghostscript
makedepends = texlive-latexextra
- depends = expat
+ depends = libxml2
optdepends = perl: for scripts in /usr/share/nusmv/contrib/
- source = http://nusmv.fbk.eu/distrib/NuSMV-2.5.4.tar.gz
- sha256sums = 3c250624cba801b1f62f50733f9507b0f3b3ca557ce1cd65956178eb273f1bdf
+ source = http://nusmv.fbk.eu/distrib/NuSMV-2.6.0.tar.gz
+ sha256sums = dba953ed6e69965a68cd4992f9cdac6c449a3d15bf60d200f704d3a02e4bbcbb
pkgname = nusmv
diff --git a/.gitignore b/.gitignore
index 1377554ebea6..3a687e89d304 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,3 @@
*.swp
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 95edcbb63fa0..4cfa69d3869b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,57 +3,32 @@
pkgname=nusmv
_pkgname=NuSMV
-pkgver=2.5.4
-pkgrel=3
+pkgver=2.6.0
+pkgrel=1
pkgdesc="A new symbolic model checker"
arch=('i686' 'x86_64')
url="http://nusmv.irst.itc.it/$_pkgname/"
license=('LGPL2.1')
-depends=('expat')
-makedepends=('ghostscript' 'texlive-latexextra')
+depends=('libxml2')
+makedepends=('cmake' 'python2' 'ghostscript' 'texlive-latexextra')
optdepends=('perl: for scripts in /usr/share/nusmv/contrib/')
source=("http://nusmv.fbk.eu/distrib/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('3c250624cba801b1f62f50733f9507b0f3b3ca557ce1cd65956178eb273f1bdf')
-
-prepare() {
- cd "$srcdir/$_pkgname-$pkgver"
-
- # Should be only one cudd-* directory, * being whatever the bundled version of cudd is
- cd ./cudd-*
- # Use arch-specific makefile for cudd
- if [ "$CARCH" == "x86_64" ]
- then
- mv Makefile Makefile_32bit
- ln -s Makefile_64bit Makefile
- fi
-
- # Fix missing DESTDIR in doc makefile paths
- cd "../$pkgname/doc/"
- find "./" -mindepth 2 -name 'Makefile.in' -not -path "./html/*" | xargs sed -i -e 's/$(datadir)/$(DESTDIR)$(datadir)/'
-}
+sha256sums=('dba953ed6e69965a68cd4992f9cdac6c449a3d15bf60d200f704d3a02e4bbcbb')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$_pkgname-$pkgver/$_pkgname"
- # Should be only one cudd-* directory, * being whatever the bundled version of cudd is
- cd "./cudd-"*
+ mkdir build
+ cd build
+ cmake .. -DPYTHON_EXECUTABLE=/bin/python2 -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev
make
-
- cd "../$pkgname"
- ./configure --prefix="/usr"
- # Work around compilation hang when -O2 is active
- make CFLAGS="$CFLAGS -O1"
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$_pkgname-$pkgver/$_pkgname/build"
- cd "./$pkgname"
make DESTDIR="$pkgdir/" install
- # Fix srcdir ref
- sed -r -e 's,^(cudddir=).*/(cudd-[0-9.]+/?)$,\1/usr/include/\2,' -i "$pkgdir/usr/lib/pkgconfig/nusmv-2.pc"
-
# Lowercase symlink
- ln -s "/usr/bin/NuSMV" "$pkgdir/usr/bin/nusmv"
+ ln -s "/usr/bin/NuSMV" "$pkgdir/usr/bin/$pkgname"
}