summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Ziemba2015-06-27 01:37:45 -0400
committerDan Ziemba2015-06-27 01:39:06 -0400
commit2df5c0adc6563b3a3a66b89ee1b424df34b3a53f (patch)
tree9c61ded72245e9c8e883c77b180d90a2a4c5ba3a
downloadaur-2df5c0adc6563b3a3a66b89ee1b424df34b3a53f.tar.gz
Initial import to AUR 4
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD42
-rw-r--r--nut-monitor.appdata.xml42
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d986c708c84a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nut-monitor
+ pkgdesc = GUI to manage devices connected a NUT server
+ pkgver = 2.7.2
+ pkgrel = 2
+ url = http://www.networkupstools.org/
+ arch = any
+ license = GPL3
+ makedepends = desktop-file-utils
+ depends = network-ups-tools
+ depends = python2
+ source = http://www.networkupstools.org/source/2.7/nut-2.7.2.tar.gz
+ source = nut-monitor.appdata.xml
+ sha256sums = 4d5365359b059d96dfcb77458f361a114d26c84f1297ffcd0c6c166f7200376d
+ sha256sums = ed8915ca01d3df7cde418199679e5165d0a81996888689011dc4f80f6f56bec6
+
+pkgname = nut-monitor
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8d95b04517dd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+nut-*.tar.gz
+pkg
+src
+*.log
+*.pkg.tar.xz
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ec4f0ea82d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Dan Ziemba <zman0900@gmail.com>
+
+pkgname=nut-monitor
+pkgver=2.7.2
+pkgrel=2
+pkgdesc="GUI to manage devices connected a NUT server"
+arch=('any')
+url="http://www.networkupstools.org/"
+# nut/scripts/python/README says GPL3, but appdata file in git says CCO-1.0
+license=('GPL3')
+depends=('network-ups-tools' 'python2')
+makedepends=('desktop-file-utils')
+source=("http://www.networkupstools.org/source/2.7/nut-$pkgver.tar.gz"
+ 'nut-monitor.appdata.xml')
+sha256sums=('4d5365359b059d96dfcb77458f361a114d26c84f1297ffcd0c6c166f7200376d'
+ 'ed8915ca01d3df7cde418199679e5165d0a81996888689011dc4f80f6f56bec6')
+
+prepare() {
+ cd "$srcdir/nut-$pkgver"
+
+ sed -i 's|=NUT-Monitor|=nut-monitor|' scripts/python/app/nut-monitor.desktop
+ sed -i 's|=nut-monitor.png|=nut-monitor|' scripts/python/app/nut-monitor.desktop
+ sed -i 's|os.path.dirname( sys.argv\[0\] )|"/usr/share/nut-monitor"|' scripts/python/app/NUT-Monitor
+ sed -i 's|/usr/bin/env python|/usr/bin/env python2.7|' scripts/python/app/NUT-Monitor
+}
+
+package() {
+ cd "$srcdir/nut-$pkgver"
+
+ install -D -m644 scripts/python/module/PyNUT.py $pkgdir/usr/lib/python2.7/site-packages/PyNUT.py
+
+ install -D -m 755 scripts/python/app/NUT-Monitor $pkgdir/usr/bin/nut-monitor
+ install -D -m 644 scripts/python/app/nut-monitor.png $pkgdir/usr/share/pixmaps/nut-monitor.png
+ # Appdata file taken from git, should be in next release
+ install -D -m 644 $srcdir/nut-monitor.appdata.xml $pkgdir/usr/share/appdata/nut-monitor.appdata.xml
+
+ install -d -m 755 $pkgdir/usr/share/nut-monitor/pixmaps
+ install -m 644 scripts/python/app/gui-1.3.glade $pkgdir/usr/share/nut-monitor/
+ install -m 644 scripts/python/app/pixmaps/* $pkgdir/usr/share/nut-monitor/pixmaps/
+
+ desktop-file-install --dir=$pkgdir/usr/share/applications scripts/python/app/nut-monitor.desktop
+}
diff --git a/nut-monitor.appdata.xml b/nut-monitor.appdata.xml
new file mode 100644
index 000000000000..ba1d0b9720a7
--- /dev/null
+++ b/nut-monitor.appdata.xml
@@ -0,0 +1,42 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Copyright 2014 Arnaud Quette <arnaud.quette@free.fr> -->
+<application>
+ <id type="desktop">nut-monitor.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-3.0+</project_license>
+ <name>NUT Monitor</name>
+ <summary>GUI application to monitor UPS status</summary>
+ <description>
+ <p>
+ NUT Monitor is a GUI application to monitor UPS status, through NUT -
+ Network UPS Tools.
+ NUT is a client/server monitoring system that allows computers to
+ share uninterruptible power supply (UPS) and power distribution unit
+ (PDU) hardware. Clients access the hardware through the server, and
+ are notified whenever the power status changes.
+ </p>
+ <p>NUT Monitor provides the following features:</p>
+ <ul>
+ <li>Automatically connects to local UPS if there is only one managed</li>
+ <li>Command line options to start hidden, load a favorite, ...</li>
+ <li>System tray (notification area) integration, including notifications</li>
+ <li>Favorites, to store different devices</li>
+ <li>Display all device variables</li>
+ <li>Modify writable variables on UPS and devices</li>
+ <li>Support English and French</li>
+ </ul>
+ <p>
+ NUT Monitor requires that you have a running NUT system, that you can
+ connect to, either locally or remotely.
+ For more information on NUT: http://www.networkupstools.org/
+ </p>
+ </description>
+ <screenshots>
+ <screenshot type="default" width="620" height="349">http://www.lestat.st/_media/informatique/projets/nut-monitor/nut-monitor-1.png</screenshot>
+ <screenshot width="620" height="349">http://www.lestat.st/_media/informatique/projets/nut-monitor/nut-monitor-2.png</screenshot>
+ <screenshot width="620" height="349">http://www.lestat.st/_media/informatique/projets/nut-monitor/nut-monitor-3.png</screenshot>
+ </screenshots>
+ <url type="homepage">http://www.lestat.st/en/informatique/projets/nut-monitor</url>
+ <updatecontact>david@lestat.st</updatecontact>
+ <!-- project_group>GNOME</project_group -->
+</application>