summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBhoppi Chaw2016-08-04 06:00:47 +0800
committerBhoppi Chaw2016-08-04 06:00:47 +0800
commit33d8aabd9725e03c7e42e5e7217141ad731d7448 (patch)
tree5f61ffe7b4e7f353ed6114e7b140279474a84f00
parentba64af22c8f1446f7418c1a7ea1b641fd5704193 (diff)
downloadaur-33d8aabd9725e03c7e42e5e7217141ad731d7448.tar.gz
now automatically fix autostart issue; add a executable in /usr/bin
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
-rwxr-xr-xnutstore4
-rw-r--r--nutstore.install21
4 files changed, 19 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13951d3ff489..a070a98cd6b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Wed Aug 3 21:58:05 UTC 2016
pkgbase = nutstore-experimental
pkgdesc = Nutstore experimental version.
pkgver = 3.3.2
- pkgrel = 1
+ pkgrel = 2
url = https://jianguoyun.com/
- install = nutstore.install
arch = x86_64
arch = i686
license = custom
@@ -13,7 +14,9 @@ pkgbase = nutstore-experimental
optdepends = nautilus-nutstore: Nautilus plugin
provides = nutstore
conflicts = nutstore
+ source = nutstore
source = license
+ md5sums = be61391e4752490bdf8a402413d79814
md5sums = 3d2b5207cb2f8faeb22625976953151d
source_x86_64 = https://jianguoyun.com/static/exe/ex/3.3.2/nutstore_client-3.3.2-linux-x64.tar.gz
md5sums_x86_64 = 36dd79961502afaef2d5d82f7909400e
diff --git a/PKGBUILD b/PKGBUILD
index 233d71c4774a..63868c643753 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nutstore-experimental
pkgver=3.3.2
-pkgrel=1
+pkgrel=2
pkgdesc='Nutstore experimental version.'
arch=(x86_64 i686)
url='https://jianguoyun.com/'
@@ -11,11 +11,10 @@ depends=(gtk2
java-runtime
python2-notify)
optdepends=('nautilus-nutstore: Nautilus plugin')
-install='nutstore.install'
-source=(license)
+source=(nutstore license)
source_x86_64=("https://jianguoyun.com/static/exe/ex/$pkgver/nutstore_client-$pkgver-linux-x64.tar.gz")
source_i686=("https://jianguoyun.com/static/exe/ex/$pkgver/nutstore_client-$pkgver-linux-x86.tar.gz")
-md5sums=(3d2b5207cb2f8faeb22625976953151d)
+md5sums=(be61391e4752490bdf8a402413d79814 3d2b5207cb2f8faeb22625976953151d)
md5sums_x86_64=(36dd79961502afaef2d5d82f7909400e)
md5sums_i686=(f9a180369f6ceef58cf4f2cc20355ad4)
conflicts=(nutstore)
@@ -24,20 +23,19 @@ provides=(nutstore)
build()
{
cd $srcdir
- sed -i -e '1s/python/python2/' bin/nutstore-pydaemon.py
+ sed -i '1s/python/python2/' bin/nutstore-pydaemon.py
cd gnome-config
- sed -i -e '/Exec=/s,~/\.nutstore/dist,/opt/nutstore,'\
- menu/nutstore-menu.desktop autostart/nutstore-daemon.desktop
+ sed -i '/Exec=/s|~/\.nutstore/dist/bin/nutstore-pydaemon.py|/usr/bin/nutstore|' menu/nutstore-menu.desktop
+ sed -i '/Exec=/s|~/\.nutstore/dist|/opt/nutstore|' autostart/nutstore-daemon.desktop
}
package()
{
cd $srcdir
- install -D -m 644 license $pkgdir/usr/share/licenses/nutstore/license
+ install -D -m755 nutstore $pkgdir/usr/bin/nutstore
+ install -D -m644 license $pkgdir/usr/share/licenses/nutstore/license
rm license *.tar.gz
mkdir -p $pkgdir/opt/nutstore && cp -aR ./ $pkgdir/opt/nutstore
- install -D -m 644 gnome-config/menu/nutstore-menu.desktop\
- $pkgdir/usr/share/applications/nutstore-menu.desktop
- install -D -m 644 app-icon/nutstore.png\
- $pkgdir/usr/share/icons/hicolor/64x64/apps/nutstore.png
+ install -D -m644 gnome-config/menu/nutstore-menu.desktop $pkgdir/usr/share/applications/nutstore.desktop
+ install -D -m644 app-icon/nutstore.png $pkgdir/usr/share/icons/hicolor/64x64/apps/nutstore.png
}
diff --git a/nutstore b/nutstore
new file mode 100755
index 000000000000..a48798abbd62
--- /dev/null
+++ b/nutstore
@@ -0,0 +1,4 @@
+#!/usr/bin/env sh
+STARTPATH='gnome-config/autostart/nutstore-daemon.desktop'
+install -CD /opt/nutstore/$STARTPATH ~/.nutstore/dist/$STARTPATH
+/opt/nutstore/bin/nutstore-pydaemon.py
diff --git a/nutstore.install b/nutstore.install
deleted file mode 100644
index 5f155fb39894..000000000000
--- a/nutstore.install
+++ /dev/null
@@ -1,21 +0,0 @@
-post_install()
-{
- update-desktop-database -q
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- cat <<EOF
-
-==> To make the option "Auto Start Nutstore" in Preferences work, type below command manually in a terminal after installation.
-$ install -D /opt/nutstore/gnome-config/autostart/nutstore-daemon.desktop ~/.nutstore/dist/gnome-config/autostart/nutstore-daemon.desktop
-
-EOF
-}
-
-post_upgrade()
-{
- post_install
-}
-
-post_remove()
-{
- post_install
-}