summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBhoppi Chaw2018-12-12 00:26:52 +0800
committerBhoppi Chaw2018-12-12 00:26:52 +0800
commit4aca473aea1427bc76e53f18ac3bdd4af8ffd0e0 (patch)
treec0ecd2e640e9eaeacee532de75995bcee876d194
parent504f59aedbff498046b36022a869a680b23637dc (diff)
downloadaur-4aca473aea1427bc76e53f18ac3bdd4af8ffd0e0.tar.gz
precompile python scripts
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ef29175498e4..3a4ba4cdc07f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,27 @@
pkgname=nutstore-experimental
pkgver=4.1.4
-pkgrel=2
+pkgrel=3
pkgdesc='Nutstore experimental version.'
arch=(x86_64)
url='https://jianguoyun.com/'
license=(custom)
depends=(libappindicator-gtk3 libnotify python-gobject)
optdepends=('nautilus-nutstore: Nautilus plugin')
+provides=(nutstore)
+conflicts=(nutstore)
source=(nutstore license)
-source_x86_64=("https://jianguoyun.com/static/exe/ex/$pkgver/nutstore_client-$pkgver-linux-x64-public.tar.gz")
sha256sums=('3091740b20ddd31ba4407b8daba1077c4677040cdc47bccfab2f7f3947676384'
'f3d2861ff48f2d193a4eced23a02b4eba9fab4c1d3f727e934ed7c59f38f0f7e')
+source_x86_64=("https://jianguoyun.com/static/exe/ex/$pkgver/nutstore_client-$pkgver-linux-x64-public.tar.gz")
sha256sums_x86_64=('b0ec672174b7f3d100d41bb6ab8768d45cfb36aef47b5e80a3560bec8842bf84')
-conflicts=(nutstore)
-provides=(nutstore)
build() {
cd $srcdir/gnome-config
sed -i '/Exec=/s|~/\.nutstore/dist/bin/nutstore-pydaemon.py|/usr/bin/nutstore|' menu/nutstore-menu.desktop
sed -i '/Exec=/s|~/\.nutstore/dist|/opt/nutstore|' autostart/nutstore-daemon.desktop
+ cd $srcdir/bin
+ python -m compileall .
}
package() {