summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sampson2015-06-21 20:09:27 +1000
committerMike Sampson2015-06-21 20:09:27 +1000
commit996c7833aa313155600f04b9c8c6f2a6a6794ddf (patch)
tree05171d323254bfdbeca736622f505bf37505ac77
downloadaur-996c7833aa313155600f04b9c8c6f2a6a6794ddf.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--nuttcp.install14
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8bf9d58cee97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nuttcp
+ pkgdesc = TCP/UDP network testing tool - simple, easy to use, with interesting feature set.
+ pkgver = 6.1.2
+ pkgrel = 1
+ url = http://www.lcp.nrl.navy.mil/nuttcp/
+ install = nuttcp.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = ftp://ftp.lcp.nrl.navy.mil/pub/nuttcp/nuttcp-6.1.2.tar.bz2
+ md5sums = a16d4d6d5def02cea980e57feaf30500
+
+pkgname = nuttcp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..137424c38d76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Michal Soltys <soltys@ziu.info>
+
+pkgname=nuttcp
+pkgver=6.1.2
+pkgrel=1
+pkgdesc="TCP/UDP network testing tool - simple, easy to use, with interesting feature set."
+arch=(i686 x86_64)
+url="http://www.lcp.nrl.navy.mil/nuttcp/"
+license=('GPL')
+depends=('glibc')
+install=nuttcp.install
+source=(
+ ftp://ftp.lcp.nrl.navy.mil/pub/nuttcp/$pkgname-$pkgver.tar.bz2
+)
+build() {
+ cd "$startdir/src/$pkgname-$pkgver"
+ make || return 1;
+ gzip -c $pkgname.8 >$pkgname.8.gz
+ install -D -m0644 -o0 -g0 $pkgname.8.gz $startdir/pkg/usr/share/man/man8/$pkgname.8.gz
+ install -D -m0755 -o0 -g0 $pkgname-$pkgver $startdir/pkg/usr/sbin/$pkgname
+}
+md5sums=('a16d4d6d5def02cea980e57feaf30500')
diff --git a/nuttcp.install b/nuttcp.install
new file mode 100644
index 000000000000..bca2f9a9e84a
--- /dev/null
+++ b/nuttcp.install
@@ -0,0 +1,14 @@
+post_install() {
+ cat <<EOF
+Note, that manpage included can have a little outdated information.
+The same goes for nuttcp -h output.
+Please review top of the nuttcp-6.1.2.c file for detailed changelog.
+EOF
+
+}
+
+post_upgrade() {
+ post_install "$@"
+}
+
+# vim:set ts=2 sw=2 et: