summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortydell2018-04-21 21:59:46 +0200
committertydell2018-04-21 21:59:46 +0200
commite3f75aade06458f7128578f234fb7ec34092a6cb (patch)
tree314539e26b47a8def0199b074a3cc0e2468fdf14
downloadaur-e3f75aade06458f7128578f234fb7ec34092a6cb.tar.gz
Initial release
-rw-r--r--.SRCINFO25
-rwxr-xr-xPKGBUILD43
-rwxr-xr-xnutty.install16
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef01d4ffc7e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = nutty-git
+ pkgdesc = A network utility for linux. Monitor the devices on your network and check bandwidth and speed details.
+ pkgver = 82.6877a87
+ pkgrel = 1
+ url = https://github.com/babluboy/nutty
+ install = nutty.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = vala
+ makedepends = git
+ makedepends = cmake
+ depends = gtk3
+ depends = granite
+ depends = sqlite
+ depends = libxml2
+ depends = libnotify
+ depends = libgee
+ provides = nutty-git
+ conflicts = nutty-git
+ source = git+https://github.com/babluboy/nutty.git
+ sha256sums = SKIP
+
+pkgname = nutty-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..f75a70f502cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Marcin Tydelski <marcin.tydelski@gmail.com>
+# Contributor: Siddhartha Das <https://github.com/babluboy, bablu.boy@gmail.com>
+
+pkgname=nutty-git
+pkgver=82.6877a87
+pkgrel=1
+_gitname=nutty
+pkgdesc='A network utility for linux. Monitor the devices on your network and check bandwidth and speed details.'
+arch=('i686' 'x86_64')
+url='https://github.com/babluboy/nutty'
+license=('GPL3')
+depends=('gtk3' 'granite' 'sqlite' 'libxml2' 'libnotify' 'libgee')
+optdepends=()
+makedepends=('vala' 'git' 'cmake')
+provides=("${pkgname%}")
+conflicts=("${pkgname%}")
+install="${pkgname%-*}.install"
+source=('git+https://github.com/babluboy/nutty.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd $_gitname
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd $_gitname/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/nutty.install b/nutty.install
new file mode 100755
index 000000000000..826f632e9bfa
--- /dev/null
+++ b/nutty.install
@@ -0,0 +1,16 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+post_remove() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file