summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Konarev2017-07-01 13:05:00 +0300
committerAlexander Konarev2017-07-01 13:05:00 +0300
commit0f238ff814c6faa7d44f68342f8c2a4fd374df76 (patch)
tree3382f5c156328e38d16e8ac5a89da3a3e2e70790
downloadaur-0f238ff814c6faa7d44f68342f8c2a4fd374df76.tar.gz
First commit
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD44
-rw-r--r--nuvola.install36
3 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5ae0bffb1ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+# Generated by mksrcinfo v8
+# Sat Jul 1 10:04:03 UTC 2017
+pkgbase = nuvolaplayer_3.0
+ pkgdesc = Cloud music integration for your Linux desktop stable 3.0 branch.
+ pkgver = 3.0.8
+ pkgrel = 1
+ url = https://tiliado.eu/nuvolaplayer/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python
+ makedepends = vala
+ depends = diorite_0.2.x
+ depends = webkit2gtk
+ depends = libarchive
+ optdepends = nuvola-app-8tracks: 8tracks.com integration
+ optdepends = nuvola-app-amazon-cloud-player: Amazon Cloud Player integration
+ optdepends = nuvola-app-bandcamp: Bandccamp integration
+ optdepends = nuvola-app-deezer: Deezer integration
+ optdepends = nuvola-app-google-play-music: Google Play Music integration
+ optdepends = nuvola-app-groove: Microsoft Groove Music integration
+ optdepends = nuvola-app-jango: Jango integration
+ optdepends = nuvola-app-logitech-media-server: Logitech Media Server integration
+ optdepends = nuvola-app-mixcloud: Mixcloud integration
+ optdepends = nuvola-app-plex: Plex Media integration
+ optdepends = nuvola-app-soundcloud: SoundCloud integration
+ optdepends = nuvola-app-spotify: Spotify integration
+ optdepends = nuvola-app-tunein: TuneIn integration
+ optdepends = nuvola-app-yandex-music: Yandex.Music integration
+ source = nuvolaplayer-3.0.8.tar.gz::https://github.com/tiliado/nuvolaplayer/archive/3.0.8.tar.gz
+ sha256sums = d160ab23db432ac8ddaa75e3be931a7eb8e70d66f762acc283cb4cb1946dcd30
+
+pkgname = nuvolaplayer_3.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb9a9175cb47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: avkonarev <avkonarev@gmail.com>
+
+pkgname=nuvolaplayer_3.0
+_pkgname=nuvolaruntime
+pkgver=3.0.8
+pkgrel=1
+
+arch=('i686' 'x86_64')
+license=('GPL')
+pkgdesc='Cloud music integration for your Linux desktop stable 3.0 branch.'
+url='https://tiliado.eu/nuvolaplayer/'
+
+source=("nuvolaplayer-${pkgver}.tar.gz::https://github.com/tiliado/nuvolaplayer/archive/${pkgver}.tar.gz")
+sha256sums=('d160ab23db432ac8ddaa75e3be931a7eb8e70d66f762acc283cb4cb1946dcd30')
+
+depends=('diorite_0.2.x' 'webkit2gtk' 'libarchive')
+makedepends=('python' 'vala')
+optdepends=(
+ 'nuvola-app-8tracks: 8tracks.com integration'
+ 'nuvola-app-amazon-cloud-player: Amazon Cloud Player integration'
+ 'nuvola-app-bandcamp: Bandccamp integration'
+ 'nuvola-app-deezer: Deezer integration'
+ 'nuvola-app-google-play-music: Google Play Music integration'
+ 'nuvola-app-groove: Microsoft Groove Music integration'
+ 'nuvola-app-jango: Jango integration'
+ 'nuvola-app-logitech-media-server: Logitech Media Server integration'
+ 'nuvola-app-mixcloud: Mixcloud integration'
+ 'nuvola-app-plex: Plex Media integration'
+ 'nuvola-app-soundcloud: SoundCloud integration'
+ 'nuvola-app-spotify: Spotify integration'
+ 'nuvola-app-tunein: TuneIn integration'
+ 'nuvola-app-yandex-music: Yandex.Music integration'
+)
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python ./waf configure --prefix=/usr
+ python ./waf build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python ./waf install --no-system-hooks --destdir="${pkgdir}"
+}
diff --git a/nuvola.install b/nuvola.install
new file mode 100644
index 000000000000..496e76f0d6f3
--- /dev/null
+++ b/nuvola.install
@@ -0,0 +1,36 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+#
+#}
+
+## arg 1: the new package version
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor/
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ # do something here
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor/
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ echo "If nuvolaplayer is freezen after upgrade, try to delete ~/.local/share/nuvolaplayer"
+}
+
+## arg 1: the old package version
+#pre_remove() {
+#}
+
+# arg 1: the old package version
+#post_remove() {
+#}
+
+# vim:set ts=2 sw=2 et: