summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Westover2021-07-15 00:13:22 -0400
committerBen Westover2021-07-15 00:13:22 -0400
commit461792ba026445fe1fb50730f0a40c4549a4c476 (patch)
treedecf73dcc58c17735b8f4a3c10aff7c3816d6eb1
parent80967315ed998d497c0a7c38ca493effa4acaaf2 (diff)
downloadaur-461792ba026445fe1fb50730f0a40c4549a4c476.tar.gz
Add .desktop file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--nuxhash-gui.desktop10
3 files changed, 22 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01121abd687c..0207ab3a1f4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = nuxhash-git
pkgdesc = A NiceHash cryptocurrency mining client for Linux.
pkgver = v1.0.0b2.r33.g33e9a09
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/YoRyan/nuxhash
arch = x86_64
arch = i686
license = GPL3
- makedepends = python-pip
depends = python
depends = curl
depends = nvidia
depends = opencl-nvidia
optdepends = python-wxpython: GUI support
source = git+https://github.com/YoRyan/nuxhash.git
+ source = nuxhash-gui.desktop
sha256sums = SKIP
+ sha256sums = 779c28c990c97b6c6fb2b2ad1cf84ff99dcdf5c1b72f034750994fdc8a645055
pkgname = nuxhash-git
-
diff --git a/PKGBUILD b/PKGBUILD
index df35fd750914..294d4b39a04a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
pkgname='nuxhash-git'
pkgver=v1.0.0b2.r33.g33e9a09
-pkgrel=1
+pkgrel=2
pkgdesc="A NiceHash cryptocurrency mining client for Linux."
arch=('x86_64' 'i686')
url="https://github.com/YoRyan/nuxhash"
license=('GPL3')
depends=('python' 'curl' 'nvidia' 'opencl-nvidia')
-makedepends=('python-pip')
optdepends=('python-wxpython: GUI support')
-source=("git+https://github.com/YoRyan/nuxhash.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/YoRyan/nuxhash.git"
+ "nuxhash-gui.desktop")
+sha256sums=('SKIP'
+ '779c28c990c97b6c6fb2b2ad1cf84ff99dcdf5c1b72f034750994fdc8a645055')
pkgver() {
cd nuxhash
@@ -19,5 +20,8 @@ pkgver() {
}
package() {
- pip install ./nuxhash --root "$pkgdir" --no-warn-script-location
+ cd nuxhash
+ python3 setup.py install --root "${pkgdir}/"
+ install -Dm644 nuxhash/gui/icons/nuxhash.svg "$pkgdir/usr/share/pixmaps/nuxhash.svg"
+ install -Dm644 ../nuxhash-gui.desktop "$pkgdir/usr/share/applications/nuxhash-gui.desktop"
}
diff --git a/nuxhash-gui.desktop b/nuxhash-gui.desktop
new file mode 100644
index 000000000000..4b78ded88a48
--- /dev/null
+++ b/nuxhash-gui.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=Nuxhash
+Comment=A NiceHash cryptocurrency mining client for Linux.
+Exec=nuxhash-gui %u
+Terminal=false
+Type=Application
+Icon=nuxhash
+MimeType=x-scheme-handler/btchd;
+Categories=Internet;Finance;P2P;Network;Qt;