summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2024-04-11 01:42:19 +0300
committerAdrian Perez de Castro2024-04-11 01:42:19 +0300
commit19eb116a30f0d39b2e46666046669a7f332bc64a (patch)
treeec94cc0f3879cf54423bfc9627357d1de68953af
parentd4cef0ac60b1bc468300dfb6112eade5b9168448 (diff)
downloadaur-nvc.tar.gz
Bump to version 1.12.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b52e98074d60..f0a5d5bcec86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,27 @@
pkgbase = nvc
pkgdesc = VHDL compiler and simulator
- pkgver = 1.9.2
- pkgrel = 2
+ pkgver = 1.12.0
+ pkgrel = 1
url = https://www.nickg.me.uk/nvc
arch = x86_64
arch = i686
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = pkgconfig
makedepends = make
makedepends = flex
makedepends = check
makedepends = llvm
- makedepends = tcl
makedepends = automake
makedepends = autoconf
depends = libelf
depends = llvm-libs
depends = ncurses
depends = zstd
+ depends = tcl
+ depends = capstone
optdepends = ruby: for the scripts to download and install VHDL libraries
conflicts = nvc-git
- source = https://www.nickg.me.uk/files/nvc-1.9.2.tar.gz
- b2sums = 0da9116aa9fdffa674cc784832ef0d479da70b14dc283a7dac8df7ea9068025f65d4fbeca5f05e62db4b6d0bf7a2bc5c579104f78f75d41c14a27acc65e3c642
+ source = https://www.nickg.me.uk/files/nvc-1.12.0.tar.gz
+ b2sums = aabcb87668e4675970a7cbebb72243074ad5db486ad2150359fc19f4c9b5629ca618c3cdb424d3639d1050477036c101cacdc4fac7dd64955c89c96fa653def3
pkgname = nvc
diff --git a/PKGBUILD b/PKGBUILD
index cf94d72fc687..9539f3f7b9ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgdesc='VHDL compiler and simulator'
pkgname=nvc
-pkgver=1.9.2
-pkgrel=2
+pkgver=1.12.0
+pkgrel=1
url=https://www.nickg.me.uk/nvc
-license=(GPL3)
+license=(GPL-3.0-or-later)
conflicts=(nvc-git)
arch=(x86_64 i686)
-depends=(libelf llvm-libs ncurses zstd)
-makedepends=(pkgconfig make flex check llvm tcl automake autoconf)
+depends=(libelf llvm-libs ncurses zstd tcl capstone)
+makedepends=(pkgconfig make flex check llvm automake autoconf)
optdepends=('ruby: for the scripts to download and install VHDL libraries')
-source=("${url%/nvc}/files/${pkgname}-${pkgver%.0}.tar.gz")
-b2sums=('0da9116aa9fdffa674cc784832ef0d479da70b14dc283a7dac8df7ea9068025f65d4fbeca5f05e62db4b6d0bf7a2bc5c579104f78f75d41c14a27acc65e3c642')
+source=("${url%/nvc}/files/${pkgname}-${pkgver}.tar.gz")
+b2sums=('aabcb87668e4675970a7cbebb72243074ad5db486ad2150359fc19f4c9b5629ca618c3cdb424d3639d1050477036c101cacdc4fac7dd64955c89c96fa653def3')
build () {
- cd "${pkgname}-${pkgver%.0}"
+ cd "${pkgname}-${pkgver}"
rm -rf _build
mkdir _build
@@ -26,10 +26,11 @@ build () {
../configure \
--prefix=/usr \
--disable-dependency-tracking \
- --enable-jit \
+ --enable-silent-rules \
--enable-verilog \
--enable-vital \
- --enable-lto \
+ --enable-server \
+ --enable-tcl \
--with-llvm=/usr/bin/llvm-config \
--with-bash-completion=/usr/share/bash-completion \
--with-ncurses
@@ -37,13 +38,12 @@ build () {
}
check () {
- cd "${pkgname}-${pkgver%.0}/_build"
- # TODO: Currently one test case fails.
- # make check
+ # TODO: Currently three test cases fail.
+ : make -C "${pkgname}-${pkgver}/_build" check
}
package () {
- cd "${pkgname}-${pkgver%.0}"
+ cd "${pkgname}-${pkgver}"
make -C_build DESTDIR="${pkgdir}" install
install -Dm755 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md