diff options
author | Norbert Preining | 2024-11-05 00:03:39 +0900 |
---|---|---|
committer | Norbert Preining | 2024-11-05 00:03:39 +0900 |
commit | 910ef7e367daad0224118319d1421e844394c135 (patch) | |
tree | 0915f2ea414b7e9816d88103c20aad3cd1dd0602 | |
parent | 4c58753c2b7e7ebb74282bc4caa6b7324df7fbbf (diff) | |
download | aur-910ef7e367daad0224118319d1421e844394c135.tar.gz |
Fix missing build-dep, add upstream patch for hdr10plus lib usage
-rw-r--r-- | .SRCINFO | 5 | ||||
-rw-r--r-- | 0001-libhdr10plus.patch | 49 | ||||
-rw-r--r-- | PKGBUILD | 11 |
3 files changed, 60 insertions, 5 deletions
@@ -1,12 +1,13 @@ pkgbase = nvenc pkgdesc = NVIDIA Video Codec based command line encoder pkgver = 7.73 - pkgrel = 1 + pkgrel = 2 url = https://github.com/rigaya/NVEnc arch = x86_64 license = MIT makedepends = git makedepends = gcc13 + makedepends = cargo-c depends = cuda>=10 depends = ffmpeg depends = libass @@ -15,8 +16,10 @@ pkgbase = nvenc source = git+https://github.com/rigaya/NVEnc.git#tag=7.73 source = git+https://github.com/tplgy/cppcodec.git source = ldflags-adjustments.patch + source = 0001-libhdr10plus.patch sha256sums = 14419a24e585fd688b92852b116d18393eba7914f5b8045ab1a52890f49015e3 sha256sums = SKIP sha256sums = 9032a642a66219efe9413cee1cb371ca3f46de254c6b50f3605df3f385ec53a5 + sha256sums = 22444dff34195710a8f85f0449b3332e42c52fe325fea0c30fb4641be9f58056 pkgname = nvenc diff --git a/0001-libhdr10plus.patch b/0001-libhdr10plus.patch new file mode 100644 index 000000000000..0b2599b32e4f --- /dev/null +++ b/0001-libhdr10plus.patch @@ -0,0 +1,49 @@ +From a29eb7e459f80308c7cff77ad749cbe5e60e35c1 Mon Sep 17 00:00:00 2001 +From: rigaya <rigaya34589@live.jp> +Date: Sun, 3 Nov 2024 09:49:38 +0900 +Subject: [PATCH 1/2] =?UTF-8?q?libhdr10plus=E9=96=A2=E9=80=A3=E3=81=AE?= + =?UTF-8?q?=E4=BF=AE=E6=AD=A3=E3=80=82?= +MIME-Version: 1.0 +Content-Type: text/plain; charset=UTF-8 +Content-Transfer-Encoding: 8bit + +--- + NVEncCore/rgy_hdr10plus.cpp | 10 +++++++--- + 1 file changed, 7 insertions(+), 3 deletions(-) + +diff --git a/NVEncCore/rgy_hdr10plus.cpp b/NVEncCore/rgy_hdr10plus.cpp +index 964cabbd..a4712ae2 100644 +--- a/NVEncCore/rgy_hdr10plus.cpp ++++ b/NVEncCore/rgy_hdr10plus.cpp +@@ -42,8 +42,8 @@ + #endif
+
+ RGYHDR10Plus::RGYHDR10Plus() :
+- m_inputJson(),
+- m_hdr10plusJson(std::unique_ptr<Hdr10PlusRsJsonOpaque, funcHdr10PlusRsJsonOpaqueDelete>(nullptr, nullptr)) {
++ m_hdr10plusJson(std::unique_ptr<Hdr10PlusRsJsonOpaque, funcHdr10PlusRsJsonOpaqueDelete>(nullptr, nullptr)),
++ m_inputJson() {
+ }
+
+ RGYHDR10Plus::~RGYHDR10Plus() {
+@@ -64,12 +64,16 @@ RGY_ERR RGYHDR10Plus::init(const tstring &inputJson) { + }
+ return RGY_ERR_NONE;
+ #else
+- reutnr RGY_ERR_UNSUPPORTED;
++ return RGY_ERR_UNSUPPORTED;
+ #endif
+ }
+
+ tstring RGYHDR10Plus::getError() {
++#if ENABLE_LIBHDR10PLUS
+ return (m_hdr10plusJson) ? char_to_tstring(hdr10plus_rs_json_get_error(m_hdr10plusJson.get())) : tstring();
++#else
++ return tstring();
++#endif
+ }
+
+ const std::vector<uint8_t> RGYHDR10Plus::getData(int iframe) {
+-- +2.47.0 + @@ -2,7 +2,7 @@ _UpstreamPkgName=NVEnc pkgname=${_UpstreamPkgName,,} pkgver=7.73 -pkgrel=1 +pkgrel=2 pkgdesc="NVIDIA Video Codec based command line encoder" arch=('x86_64') url="https://github.com/rigaya/$_UpstreamPkgName" @@ -10,17 +10,20 @@ license=('MIT') # While cuda and nvidia are not strictly necessary accoring the ldd # the program will not work at all without them installed. depends=('cuda>=10' 'ffmpeg' 'libass' 'vapoursynth' 'libdovi') -makedepends=('git' 'gcc13') +makedepends=('git' 'gcc13' 'cargo-c') source=(git+${url}.git#tag=${pkgver} git+https://github.com/tplgy/cppcodec.git - ldflags-adjustments.patch) + ldflags-adjustments.patch + 0001-libhdr10plus.patch) sha256sums=('14419a24e585fd688b92852b116d18393eba7914f5b8045ab1a52890f49015e3' 'SKIP' - '9032a642a66219efe9413cee1cb371ca3f46de254c6b50f3605df3f385ec53a5') + '9032a642a66219efe9413cee1cb371ca3f46de254c6b50f3605df3f385ec53a5' + '22444dff34195710a8f85f0449b3332e42c52fe325fea0c30fb4641be9f58056') prepare() { cd $_UpstreamPkgName patch --forward --strip=1 --input="${srcdir}/ldflags-adjustments.patch" + patch --forward --strip=1 --input="${srcdir}/0001-libhdr10plus.patch" } build() { |