summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2020-05-10 23:16:32 +0200
committerMagnus Boman2020-05-10 23:16:32 +0200
commitbcd30a338fb8d6b26c241288ad45293b5ee03e07 (patch)
tree3895d69ded66141e53c807d0f23568bfe9cf1ae1
downloadaur-bcd30a338fb8d6b26c241288ad45293b5ee03e07.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b9a9c53e979
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = nvfancontrol-git
+ pkgdesc = NVidia dynamic fan control
+ pkgver = 0.3.r45.g0ba7ba3
+ pkgrel = 1
+ url = https://github.com/foucault/nvfancontrol
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ makedepends = libxnvctrl
+ depends = libxext
+ optdepends = nvidia: For GTX 4xx or newer cards
+ optdepends = nvidia-340xx: For G8x, G9x and GTX 2xx cards
+ provides = nvfancontrol
+ conflicts = nvfancontrol
+ source = nvfancontrol-git::git+https://github.com/foucault/nvfancontrol
+ sha256sums = SKIP
+
+pkgname = nvfancontrol-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..939f648ca753
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: katt <magunasu.b97@gmail.com>
+
+_pkgname=nvfancontrol
+pkgname=$_pkgname-git
+pkgver=0.3.r45.g0ba7ba3
+pkgrel=1
+pkgdesc="NVidia dynamic fan control"
+arch=('i686' 'x86_64')
+url="https://github.com/foucault/nvfancontrol"
+license=('GPL3')
+depends=('libxext')
+makedepends=('cargo' 'libxnvctrl')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+optdepends=('nvidia: For GTX 4xx or newer cards'
+ 'nvidia-340xx: For G8x, G9x and GTX 2xx cards')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+package() {
+ install -Dm755 "$pkgname/target/release/$_pkgname" -t "$pkgdir/usr/bin"
+}