summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco La Camera2022-09-25 20:03:20 +0200
committerFrancesco La Camera2022-09-25 20:03:20 +0200
commitf23d451d065b35bd6daedb3808d61cb4b11b5ca9 (patch)
tree6b1e072c81208afd5fe1c8ea351825298f45af9d
parent6d74315e75b0ae090035cb947ce1b6c340bc68fe (diff)
downloadaur-nvi.tar.gz
patch has been merged upstream, remove from build
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
-rw-r--r--fixerrors.patch60
3 files changed, 11 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b22df044466..88c593d0050f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
-# Maintainer: Francesco La Camera <fm@lacamera.org>
pkgbase = nvi
- pkgdesc = The Berkley Vi Editor
+ pkgdesc = Portable OpenBSD vi, originally distributed as part of 4BSD.
pkgver = 1.79
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/lacamera/nvi
arch = i686
arch = x86_64
@@ -10,9 +9,7 @@ pkgbase = nvi
depends = libtool
depends = readline
depends = ncurses
- source = https://github.com/lacamera/nvi.git
- source = fixerrors.patch
+ source = git+https://github.com/lacamera/nvi.git
md5sums = SKIP
- md5sums = 0bbe8609c1e2866ed239af14c065a6bb
-pkgname = nvi
+pkgname = nvi
diff --git a/PKGBUILD b/PKGBUILD
index 5612dabe6832..5b947868cac4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,16 @@
# Maintainer: Francesco La Camera <fm@lacamera.org>
pkgname=nvi
pkgver=1.79
-pkgrel=2
-pkgdesc="The Berkeley Vi Editor"
-arch=('i686' 'x86_64')
+pkgrel=3
+pkgdesc="Portable OpenBSD vi, originally distributed as part of 4BSD."
+arch=("i686" "x86_64")
url="https://github.com/lacamera/nvi"
-license=('BSD')
-depends=('libtool' 'readline' 'ncurses')
-source=("git+https://github.com/lacamera/nvi.git"
- "fixerrors.patch")
-md5sums=('SKIP' '0bbe8609c1e2866ed239af14c065a6bb')
+license=("BSD")
+depends=("libtool" "readline" "ncurses")
+source=("git+https://github.com/lacamera/nvi.git")
+md5sums=("SKIP")
prepare(){
- cd "$srcdir/$pkgname"
- patch -p1 < ../fixerrors.patch
cd "$srcdir/$pkgname/build"
cp -pf /usr/share/libtool/build-aux/config.guess .
cp -pf /usr/share/libtool/build-aux/config.sub .
diff --git a/fixerrors.patch b/fixerrors.patch
deleted file mode 100644
index 0c87c4b4fed2..000000000000
--- a/fixerrors.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/build/Makefile.in
-+++ b/build/Makefile.in
-@@ -4,7 +4,7 @@ srcdir= @srcdir@/..
- CC= @CC@
- OPTFLAG=@OPTFLAG@
- CFLAGS= -c $(OPTFLAG) @CFLAGS@ -I. -I$(srcdir)/include @CPPFLAGS@
--LDFLAGS=@LDFLAGS@
-+LDFLAGS=-lreadline -lncurses
- PERL= @vi_cv_path_perl@
- PERLLIB=@vi_cv_perllib@
- SHRPENV=@shrpenv@
-@@ -139,8 +139,8 @@ install_common:
- cd $(datadir)/vi/catalog && $(chmod) $(fmode) *)
- @echo "Installing Perl scripts: $(datadir)/vi/perl ..."
- $(mkdir) $(datadir)/vi/perl && $(chmod) $(dmode) $(datadir)/vi/perl
-- [ -f VI.pm ] && $(cp) VI.pm $(datadir)/vi/perl && \
-- cd $(datadir)/vi/perl && $(chmod) $(fmode) VI.pm)
-+ #[ -f VI.pm ] && $(cp) VI.pm $(datadir)/vi/perl && \
-+ # cd $(datadir)/vi/perl && $(chmod) $(fmode) VI.pm
- (cd $(srcdir)/perl_scripts && $(cp) *.pl $(datadir)/vi/perl && \
- cd $(datadir)/vi/perl && $(chmod) $(fmode) *.pl)
- @echo "Installing Tcl scripts: $(datadir)/vi/tcl ..."
---- a/ex/ex_script.c
-+++ b/ex/ex_script.c
-@@ -23,9 +23,11 @@ static const char sccsid[] = "@(#)ex_script.c 10.30 (Berkeley) 9/24/96";
- #include <sys/select.h>
- #endif
- #include <sys/stat.h>
-+
- #ifdef HAVE_SYS5_PTY
--#include <sys/stropts.h>
-+ //#include <sys/stropts.h>
- #endif
-+
- #include <sys/time.h>
- #include <sys/wait.h>
-
-@@ -718,19 +720,19 @@ ptys_open(fdm, pts_name)
- return (-5);
- }
-
-- if (ioctl(fds, I_PUSH, "ptem") < 0) {
-+ if (ioctl(fds, TIOCPKT, "ptem") < 0) {
- close(fds);
- close(fdm);
- return (-6);
- }
-
-- if (ioctl(fds, I_PUSH, "ldterm") < 0) {
-+ if (ioctl(fds, TIOCPKT, "ldterm") < 0) {
- close(fds);
- close(fdm);
- return (-7);
- }
-
-- if (ioctl(fds, I_PUSH, "ttcompat") < 0) {
-+ if (ioctl(fds, TIOCPKT, "ttcompat") < 0) {
- close(fds);
- close(fdm);
- return (-8);