summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2017-10-16 16:54:45 +0200
committerBalló György2017-10-16 16:54:45 +0200
commit774b62fd65d3485b97d67f0203d3fac666397765 (patch)
treefebdae6f408092cd3640617389ecd02c08d8b2cb
parent2329a4330cbb77bc2c018af7dcc48f4a81fba5c7 (diff)
downloadaur-774b62fd65d3485b97d67f0203d3fac666397765.tar.gz
upgpkg: nvidia-173xx-dkms 173.14.39-11
Fix for linux>=4.12
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--linux-4.12.patch43
3 files changed, 50 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d20d0003c439..f374b42f4905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nvidia-173xx-dkms
pkgdesc = NVIDIA kernel module sources (DKMS), 173xx branch
pkgver = 173.14.39
- pkgrel = 10
+ pkgrel = 11
url = http://www.nvidia.com/
arch = i686
arch = x86_64
@@ -21,6 +21,7 @@ pkgbase = nvidia-173xx-dkms
source = linux-4.3.patch
source = linux-4.6.patch
source = linux-4.10.patch
+ source = linux-4.12.patch
source = dkms.conf
md5sums = 6dfb34d8fdf35c1637932f95d2216c46
md5sums = a2042d1f47d3f7c8b380237bd0b35863
@@ -29,6 +30,7 @@ pkgbase = nvidia-173xx-dkms
md5sums = 20bde657bb715e16295d7e82fe799fca
md5sums = a5b751e62ee8caba525c059035568422
md5sums = 8a46a9e33749ae1d4d14b1117a36d95c
+ md5sums = a776f5aa70d3c35d0d5a84a71936a37e
md5sums = d784fa643442852babc56f60705387a4
source_i686 = http://download.nvidia.com/XFree86/Linux-x86/173.14.39/NVIDIA-Linux-x86-173.14.39-pkg0.run
md5sums_i686 = 5b423543428554ef33a200fbbe3cb9fc
diff --git a/PKGBUILD b/PKGBUILD
index 104e1acc0bd7..b73236c48218 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=nvidia-173xx-dkms
pkgver=173.14.39
-pkgrel=10
+pkgrel=11
pkgdesc="NVIDIA kernel module sources (DKMS), 173xx branch"
arch=('i686' 'x86_64')
[ "$CARCH" = "i686" ] && _arch=x86
@@ -26,6 +26,7 @@ source=(linux-3.14.patch
linux-4.3.patch
linux-4.6.patch
linux-4.10.patch
+ linux-4.12.patch
dkms.conf)
source_i686=("http://download.nvidia.com/XFree86/Linux-x86/$pkgver/NVIDIA-Linux-x86-$pkgver-pkg0.run")
source_x86_64=("http://download.nvidia.com/XFree86/Linux-x86_64/$pkgver/NVIDIA-Linux-x86_64-$pkgver-pkg0.run")
@@ -36,6 +37,7 @@ md5sums=('6dfb34d8fdf35c1637932f95d2216c46'
'20bde657bb715e16295d7e82fe799fca'
'a5b751e62ee8caba525c059035568422'
'8a46a9e33749ae1d4d14b1117a36d95c'
+ 'a776f5aa70d3c35d0d5a84a71936a37e'
'd784fa643442852babc56f60705387a4')
md5sums_i686=('5b423543428554ef33a200fbbe3cb9fc')
md5sums_x86_64=('0799f194869e40141c7bac8a71762db6')
@@ -51,6 +53,7 @@ prepare() {
patch -p1 --no-backup-if-mismatch -i "$srcdir/linux-4.3.patch"
patch -p1 --no-backup-if-mismatch -i "$srcdir/linux-4.6.patch"
patch -p1 --no-backup-if-mismatch -i "$srcdir/linux-4.10.patch"
+ patch -p1 --no-backup-if-mismatch -i "$srcdir/linux-4.12.patch"
}
package() {
diff --git a/linux-4.12.patch b/linux-4.12.patch
new file mode 100644
index 000000000000..796c5ff95f78
--- /dev/null
+++ b/linux-4.12.patch
@@ -0,0 +1,43 @@
+diff -Naur nv.orig/conftest.sh nv/conftest.sh
+--- nv.orig/conftest.sh 2017-10-16 16:21:22.549358000 +0200
++++ nv/conftest.sh 2017-10-16 16:32:49.985089045 +0200
+@@ -237,7 +237,11 @@
+ # Determine if the set_pages_uc() function is present.
+ #
+ echo "$CONFTEST_PREAMBLE
+- #include <asm/cacheflush.h>
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++ #include <asm/set_memory.h>
++ #else
++ #include <asm/cacheflush.h>
++ #endif
+ void conftest_set_pages_uc(void) {
+ set_pages_uc();
+ }" > conftest$$.c
+@@ -267,8 +271,10 @@
+ #include <linux/version.h>
+ #include <linux/utsname.h>
+ #include <linux/mm.h>
+- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 0)
+- #include <asm/cacheflush.h>
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++ #include <asm/set_memory.h>
++ #elif LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 0)
++ #include <asm/cacheflush.h>
+ #endif
+ void conftest_change_page_attr(void) {
+ change_page_attr();
+diff -Naur nv.orig/nv-vm.c nv/nv-vm.c
+--- nv.orig/nv-vm.c 2013-11-27 23:47:09.000000000 +0100
++++ nv/nv-vm.c 2017-10-16 16:35:11.059602958 +0200
+@@ -14,6 +14,10 @@
+ #include "nv-linux.h"
+ #include "nv-vm.h"
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0)
++ #include <asm/set_memory.h>
++#endif
++
+ #if defined(NV_DBG_MEM)
+ #define NV_DEFAULT_LIST_PAGE_COUNT 10
+