summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2019-03-10 07:45:08 -0400
committergraysky2019-03-10 07:45:08 -0400
commitdd79ee2f991c23f251f3b6f8ada3145a79f878c9 (patch)
tree427133fc93c35db6d0be6e4e33d2710b82e43bbf
parent7cea4d32acf66d0c63ddff4d8244daa4c7817fd9 (diff)
downloadaur-dd79ee2f991c23f251f3b6f8ada3145a79f878c9.tar.gz
Update to 340.107-48
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--kernel-5.0.patch52
3 files changed, 65 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0e0b43b9673..e286f4a9c89f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
# Generated by mksrcinfo v8
-# Tue Mar 5 20:47:31 UTC 2019
+# Sun Mar 10 11:45:08 UTC 2019
pkgbase = nvidia-340xx-ck
pkgdesc = NVIDIA drivers for linux-ck, 340xx legacy branch.
pkgver = 340.107
- pkgrel = 47
+ pkgrel = 48
url = http://www.nvidia.com/
arch = x86_64
license = custom
- makedepends = linux-ck-headers>=4.20
- makedepends = linux-ck-headers<4.21
+ makedepends = linux-ck-headers
makedepends = nvidia-340xx-libgl
- depends = linux-ck>=4.20
- depends = linux-ck<4.21
+ depends = linux-ck
depends = libgl
depends = nvidia-340xx-utils=340.107
conflicts = nvidia-ck
@@ -19,8 +17,10 @@ pkgbase = nvidia-340xx-ck
options = !strip
source = http://us.download.nvidia.com/XFree86/Linux-x86_64/340.107/NVIDIA-Linux-x86_64-340.107-no-compat32.run
source = kernel-4.11.patch
+ source = kernel-5.0.patch
sha256sums = 6dc6f183c69c414670d8adef0286a2362eedd6e16ec6dfae811e48ea4a4505dc
sha256sums = 5ba7e6d5e502882c3534d1d8578f7fd29fdf3d2aeb49206efa7b3514a7e3e821
+ sha256sums = 236a1d1dc9adc1cafec828f0650d5a15f1f6d0fa27905dab58ca072a46f159fa
pkgname = nvidia-340xx-ck
diff --git a/PKGBUILD b/PKGBUILD
index f30154520d98..51e1d30d3365 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,22 +6,23 @@
pkgname=nvidia-340xx-ck
pkgver=340.107
_extramodules=extramodules-ck
-pkgrel=47
+pkgrel=48
pkgdesc="NVIDIA drivers for linux-ck, 340xx legacy branch."
arch=('x86_64')
url="http://www.nvidia.com/"
-depends=('linux-ck>=4.20' 'linux-ck<4.21' 'libgl' "nvidia-340xx-utils=${pkgver}")
-makedepends=('linux-ck-headers>=4.20' 'linux-ck-headers<4.21' 'nvidia-340xx-libgl')
+depends=('linux-ck' 'libgl' "nvidia-340xx-utils=${pkgver}")
+makedepends=('linux-ck-headers' 'nvidia-340xx-libgl')
conflicts=('nvidia-ck' 'nvidia-390xx-ck')
#groups=('ck-generic')
#replaces=()
license=('custom')
options=(!strip)
source=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run"
-'kernel-4.11.patch'
+'kernel-4.11.patch' 'kernel-5.0.patch'
)
sha256sums=('6dc6f183c69c414670d8adef0286a2362eedd6e16ec6dfae811e48ea4a4505dc'
- '5ba7e6d5e502882c3534d1d8578f7fd29fdf3d2aeb49206efa7b3514a7e3e821')
+ '5ba7e6d5e502882c3534d1d8578f7fd29fdf3d2aeb49206efa7b3514a7e3e821'
+ '236a1d1dc9adc1cafec828f0650d5a15f1f6d0fa27905dab58ca072a46f159fa')
_pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
prepare() {
@@ -30,6 +31,7 @@ prepare() {
# patches here
patch -Np0 < "${srcdir}/kernel-4.11.patch"
+ patch -Np0 < "${srcdir}/kernel-5.0.patch"
}
build() {
diff --git a/kernel-5.0.patch b/kernel-5.0.patch
new file mode 100644
index 000000000000..4786b69b6265
--- /dev/null
+++ b/kernel-5.0.patch
@@ -0,0 +1,52 @@
+--- kernel/nv-drm.c 2018-05-25 04:16:20.000000000 +0000
++++ kernel/nv-drm.c 2019-03-04 20:57:40.065280734 +0000
+@@ -252,7 +252,11 @@
+ goto done;
+ }
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 0, 0)
+ drm_gem_object_unreference_unlocked(&nv_obj->base);
++#else
++ drm_gem_object_put_unlocked(&nv_obj->base);
++#endif
+
+ status = RM_OK;
+
+--- kernel/os-interface.c 2018-05-25 04:16:20.000000000 +0000
++++ kernel/os-interface.c 2019-03-04 21:03:03.815854982 +0000
+@@ -14,6 +14,16 @@
+ #include "os-interface.h"
+ #include "nv-linux.h"
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 0, 0)
++static inline void do_gettimeofday(struct timeval *tv)
++{
++ struct timespec64 now;
++ ktime_get_real_ts64(&now);
++ tv->tv_sec = now.tv_sec;
++ tv->tv_usec = now.tv_nsec/1000;
++}
++#endif
++
+ RM_STATUS NV_API_CALL os_disable_console_access(void)
+ {
+ NV_ACQUIRE_CONSOLE_SEM();
+--- kernel/uvm/nvidia_uvm_lite.c 2019-03-04 20:57:25.815255511 +0000
++++ kernel/uvm/nvidia_uvm_lite.c 2019-03-04 21:04:25.239333050 +0000
+@@ -30,6 +30,16 @@
+ #include "nvidia_uvm_lite_counters.h"
+ #include "ctrl2080mc.h"
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 0, 0)
++static inline void do_gettimeofday(struct timeval *tv)
++{
++ struct timespec64 now;
++ ktime_get_real_ts64(&now);
++ tv->tv_sec = now.tv_sec;
++ tv->tv_usec = now.tv_nsec/1000;
++}
++#endif
++
+ //
+ // nvidia_uvm_lite.c
+ // This file contains code that is specific to the UVM-Lite mode of operation.