summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2017-04-20 17:16:45 +0200
committersirlucjan2017-04-20 17:16:45 +0200
commitc7bcdd28b624596d93f92e71e40cd9d1ca59c836 (patch)
tree6ba20edeb4f021c3359bc602ae905d4f72ea68b8
parent22c1738f9e748a33184e5d79bbc142c91c413b5b (diff)
downloadaur-c7bcdd28b624596d93f92e71e40cd9d1ca59c836.tar.gz
Bump to 4.10-series
-rw-r--r--.SRCINFO14
-rw-r--r--4.10.0_kernel.patch131
-rw-r--r--PKGBUILD14
-rw-r--r--fs52243.patch14
-rw-r--r--nvidia-340xx-lqx.install2
5 files changed, 146 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9aa842719080..1977519595e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = nvidia-340xx-lqx
pkgdesc = NVIDIA 340xx drivers for linux-lqx.
pkgver = 340.102
- pkgrel = 2
+ pkgrel = 3
url = http://www.nvidia.com/
install = nvidia-340xx-lqx.install
arch = i686
arch = x86_64
license = custom
- makedepends = linux-lqx-headers>=4.9
- makedepends = linux-lqx-headers<4.10
- depends = linux-lqx>=4.9
- depends = linux-lqx<4.10
+ makedepends = linux-lqx-headers>=4.10
+ makedepends = linux-lqx-headers<4.11
+ depends = linux-lqx>=4.10
+ depends = linux-lqx<4.11
depends = nvidia-340xx-libgl
depends = nvidia-340xx-utils=340.102
conflicts = nvidia-lqx
conflicts = nvidia-304xx-lqx
options = !strip
- source = fs52243.patch
- sha512sums = de4f697d64f8e73c4aadec1a407884a6bc459c0020d4bfd19740fe4177a60bb801fe8a74ef6f7fa2e89c6cd648ea4daf152799ae344a145c06480a6eef0c5bca
+ source = 4.10.0_kernel.patch
+ sha512sums = 88a2b448c1e8445dc43820328e86d8f20eb7e3cb5774e704cd44191a9fa26064264510c1adc9ea938fa2c92075496f3a27bd52ae6e6f4ec5fa6d4a829dd961e8
source_i686 = http://us.download.nvidia.com/XFree86/Linux-x86/340.102/NVIDIA-Linux-x86-340.102.run
sha512sums_i686 = bea700c925a6044fcded40324bb389c5fa1aadc40831f685a76e7b0ded11161f492960950c201467e564d157dcbe0c330d13a2014f51d0073002c5a262a6f0ca
source_x86_64 = http://us.download.nvidia.com/XFree86/Linux-x86_64/340.102/NVIDIA-Linux-x86_64-340.102-no-compat32.run
diff --git a/4.10.0_kernel.patch b/4.10.0_kernel.patch
new file mode 100644
index 000000000000..f4297b149e96
--- /dev/null
+++ b/4.10.0_kernel.patch
@@ -0,0 +1,131 @@
+From 983a2ca221a371e08bb5ad11758a729cfa5aa88c Mon Sep 17 00:00:00 2001
+From: Alberto Milone <alberto.milone@canonical.com>
+Date: Wed, 15 Feb 2017 17:05:55 +0100
+Subject: [PATCH 1/1] Add support for Linux 4.10
+
+---
+ nv-linux.h | 7 +++++++
+ nv-pat.c | 40 ++++++++++++++++++++++++++++++++++++++++
+ uvm/nvidia_uvm_lite.c | 4 ++++
+ 3 files changed, 51 insertions(+)
+
+diff --git a/kernel/nv-linux.h b/kernel/nv-linux.h
+index e7068e3..2d62492 100644
+--- a/kernel/nv-linux.h
++++ b/kernel/nv-linux.h
+@@ -2082,6 +2082,8 @@ static inline NvU64 nv_node_end_pfn(int nid)
+ * 2016 Dec 14:5b56d49fc31dbb0487e14ead790fc81ca9fb2c99
+ */
+
++#include <linux/version.h>
++
+ #if defined(NV_GET_USER_PAGES_REMOTE_PRESENT)
+ #if defined(NV_GET_USER_PAGES_HAS_WRITE_AND_FORCE_ARGS)
+ #define NV_GET_USER_PAGES get_user_pages
+@@ -2129,8 +2131,13 @@ static inline NvU64 nv_node_end_pfn(int nid)
+
+ #else
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
+ return get_user_pages_remote(tsk, mm, start, nr_pages, flags,
+ pages, vmas);
++#else
++ return get_user_pages_remote(tsk, mm, start, nr_pages, flags,
++ pages, vmas, NULL);
++#endif
+
+ #endif
+
+diff --git a/kernel/nv-pat.c b/kernel/nv-pat.c
+index a725533..cec6f3f 100644
+--- a/kernel/nv-pat.c
++++ b/kernel/nv-pat.c
+@@ -203,6 +203,7 @@ void nv_disable_pat_support(void)
+ }
+
+ #if defined(NV_ENABLE_PAT_SUPPORT) && defined(NV_ENABLE_HOTPLUG_CPU)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
+ static int
+ nvidia_cpu_callback(struct notifier_block *nfb, unsigned long action, void *hcpu)
+ {
+@@ -234,6 +235,34 @@ static struct notifier_block nv_hotcpu_nfb = {
+ .notifier_call = nvidia_cpu_callback,
+ .priority = 0
+ };
++#else
++static int nvidia_cpu_online(unsigned int hcpu)
++{
++ unsigned int cpu = get_cpu();
++ if (cpu == hcpu)
++ nv_setup_pat_entries(NULL);
++ else
++ NV_SMP_CALL_FUNCTION(nv_setup_pat_entries, (void *)(long int)hcpu, 1);
++
++ put_cpu();
++
++ return 0;
++}
++
++static int nvidia_cpu_down_prep(unsigned int hcpu)
++{
++ unsigned int cpu = get_cpu();
++ if (cpu == hcpu)
++ nv_restore_pat_entries(NULL);
++ else
++ NV_SMP_CALL_FUNCTION(nv_restore_pat_entries, (void *)(long int)hcpu, 1);
++
++ put_cpu();
++
++ return 0;
++}
++#endif
++
+ #endif
+
+ int nv_init_pat_support(nv_stack_t *sp)
+@@ -255,7 +284,14 @@ int nv_init_pat_support(nv_stack_t *sp)
+ #if defined(NV_ENABLE_PAT_SUPPORT) && defined(NV_ENABLE_HOTPLUG_CPU)
+ if (nv_pat_mode == NV_PAT_MODE_BUILTIN)
+ {
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
+ if (register_hotcpu_notifier(&nv_hotcpu_nfb) != 0)
++#else
++ if (cpuhp_setup_state(CPUHP_AP_ONLINE_DYN,
++ "gpu/nvidia:online",
++ nvidia_cpu_online,
++ nvidia_cpu_down_prep) != 0)
++#endif
+ {
+ nv_disable_pat_support();
+ nv_printf(NV_DBG_ERRORS,
+@@ -280,7 +316,11 @@ void nv_teardown_pat_support(void)
+ {
+ nv_disable_pat_support();
+ #if defined(NV_ENABLE_PAT_SUPPORT) && defined(NV_ENABLE_HOTPLUG_CPU)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
+ unregister_hotcpu_notifier(&nv_hotcpu_nfb);
++#else
++ cpuhp_remove_state_nocalls(CPUHP_AP_ONLINE_DYN);
++#endif
+ #endif
+ }
+ }
+diff --git a/kernel/uvm/nvidia_uvm_lite.c b/kernel/uvm/nvidia_uvm_lite.c
+index 9627f60..2158b45 100644
+--- a/kernel/uvm/nvidia_uvm_lite.c
++++ b/kernel/uvm/nvidia_uvm_lite.c
+@@ -820,7 +820,11 @@ done:
+ #if defined(NV_VM_OPERATIONS_STRUCT_HAS_FAULT)
+ int _fault(struct vm_area_struct *vma, struct vm_fault *vmf)
+ {
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
+ unsigned long vaddr = (unsigned long)vmf->virtual_address;
++#else
++ unsigned long vaddr = (unsigned long)vmf->address;
++#endif
+ struct page *page = NULL;
+ int retval;
+
+--
+2.7.4
+
diff --git a/PKGBUILD b/PKGBUILD
index 0f3cc09893b9..d1d974b2289e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,22 @@
pkgname=nvidia-340xx-lqx
pkgver=340.102
-_extramodules=extramodules-4.9-lqx
-pkgrel=2
+_extramodules=extramodules-4.10-lqx
+pkgrel=3
_pkgdesc="NVIDIA 340xx drivers for linux-lqx."
pkgdesc="$_pkgdesc"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
-depends=('linux-lqx>=4.9' 'linux-lqx<4.10' "nvidia-340xx-libgl" "nvidia-340xx-utils=${pkgver}")
-makedepends=('linux-lqx-headers>=4.9' 'linux-lqx-headers<4.10')
+depends=('linux-lqx>=4.10' 'linux-lqx<4.11' "nvidia-340xx-libgl" "nvidia-340xx-utils=${pkgver}")
+makedepends=('linux-lqx-headers>=4.10' 'linux-lqx-headers<4.11')
conflicts=('nvidia-lqx' 'nvidia-304xx-lqx')
license=('custom')
install=nvidia-340xx-lqx.install
options=(!strip)
-source=('fs52243.patch')
+source=('4.10.0_kernel.patch')
source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha512sums=('de4f697d64f8e73c4aadec1a407884a6bc459c0020d4bfd19740fe4177a60bb801fe8a74ef6f7fa2e89c6cd648ea4daf152799ae344a145c06480a6eef0c5bca')
+sha512sums=('88a2b448c1e8445dc43820328e86d8f20eb7e3cb5774e704cd44191a9fa26064264510c1adc9ea938fa2c92075496f3a27bd52ae6e6f4ec5fa6d4a829dd961e8')
sha512sums_i686=('bea700c925a6044fcded40324bb389c5fa1aadc40831f685a76e7b0ded11161f492960950c201467e564d157dcbe0c330d13a2014f51d0073002c5a262a6f0ca')
sha512sums_x86_64=('2a29e6418244ea384e4237d74057bd8e56247b1c503cf623dea34a3b1065d8783879aa7e6a802dd31f0a10cf81cfcab2a1b1a8269b97996f15fa1838c0a3a44b')
@@ -31,7 +31,7 @@ prepare() {
cd "${_pkg}"
# patches here
- patch -Np0 < "${srcdir}"/fs52243.patch
+ patch -Np1 < "${srcdir}"/4.10.0_kernel.patch
cp -a kernel kernel-dkms
}
diff --git a/fs52243.patch b/fs52243.patch
deleted file mode 100644
index b6dc35a2e7ff..000000000000
--- a/fs52243.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- kernel/nv-drm.c 2016-12-15 12:41:26.000000000 +0100
-+++ kernel/nv-drm.c 2016-12-15 12:58:48.000000000 +0100
-@@ -115,7 +115,11 @@
- };
-
- static struct drm_driver nv_drm_driver = {
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 9, 0)
-+ .driver_features = DRIVER_GEM | DRIVER_PRIME | DRIVER_LEGACY,
-+#else
- .driver_features = DRIVER_GEM | DRIVER_PRIME,
-+#endif
- .load = nv_drm_load,
- .unload = nv_drm_unload,
- .fops = &nv_drm_fops,
diff --git a/nvidia-340xx-lqx.install b/nvidia-340xx-lqx.install
index a9808d69c8b5..609622529493 100644
--- a/nvidia-340xx-lqx.install
+++ b/nvidia-340xx-lqx.install
@@ -1,5 +1,5 @@
post_install() {
- EXTRAMODULES='extramodules-4.9-lqx'
+ EXTRAMODULES='extramodules-4.10-lqx'
depmod $(cat /usr/lib/modules/${EXTRAMODULES}/version)
echo 'In order to use nvidia module, reboot the system.'
}